Jump to content

tmoulder

External Moderators
  • Content count

    185
  • Joined

  • Last visited

  • Days Won

    4

tmoulder last won the day on December 4 2013

tmoulder had the most liked content!

Community Reputation

6 Neutral

About tmoulder

  • Rank
    Moderator

Profile Information

  • Gender
    Not Telling

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hello All, So I've now tried to install Visilogic on 3 laptops in total, one running Windows 7 and 2 running Windows 10. I have three versions I am working with, 9.8.65 (latest) and 9.8.0 and 9.7.0 under Swapper. The Windows 7 laptop, after installing according to directions, including ripping Visilogic out completely and a fresh install, I cannot get 9.8.65 or 9.7.0 to work. Both throw the Runtime Error 9 subscript. Strangely, 9.8.0 loads fine. On the first Windows 10 (an Asus tablet, woefully underpowered), I can get 9.8.65 and 9.8.0 to work, but 9.7.0 throws an error. On the second Windows 10 laptop (an also-underpowered HP) I can get 9.8.0 to work, but neither of the others. So at this point, running any Visilogic reliably means loading up an XP virtual machine and running from in there, with all the performance hit that entails. I normally use Ubuntu linux at home, and I've been running apps in both Flatpak and Snap container formats. Windows doesn't support either of these (naturally) but it does support Docker. I am wondering how feasible it would be to provide Visilogic in a container, and if that would clear away some of the problems we keep having with version changes and OS updates breaking our system? Just an idea. Thanks!
  2. Hi Ausman, The original problem surfaced running on bare-metal Windows 7. I installed Visilogic into a Virtual Machine to mitigate the problem and be able to work on my equipment again. I haven't tried any compatibility mode changes yet, had a terrible experience with that many years ago. Things have probably (?) improved since then, so I may take another shot at it. Thanks for all the help! TM
  3. Thanks for the ideas guys, but it didn't help. It's not a swapper issue, this is all on Visilogic 65. I ripped it out with Revo, rebooted and reinstalled, still throws the error. Currently running Vsilogic under an XP virtual machine.
  4. I'm having the exact same problem, right after a Windows update (Win 7). I am an admin on my local machine, but following the instructions and shutting off the UAC made no difference at all. Help!
  5. Hello Unigurus! A small (hopefully simple) suggestion - give us the option to add a 1-pixel black border to HMI items, such as raised buttons and recessed indicators. Especially on certain color schemes, it gives a much cleaner look.
  6. Hi Cara! Form factor is an issue for me, this is an existing installation, with 30+ complex screens that I don't want to have to redraw. Changing the ladder program to accommodate a different sort of ethernet card would be just fine though. As for market demand, pretty sure folks have been asking for more than 4 sockets since the V280 days Thanks! Edit: On a related note, on this very project of which I speak, I have two robots and a vision system connected on Modbus TCP. I have one socket left (Socket 1) for programming via wireless router. Due to some obsolete servo drives, I are now moving to a different motion scheme, which involves a separate motion controller that connects via - you guessed it - Modbus TCP. Bye-bye convenient wireless programming, hello serial port. So this one is kind of a big deal for me, personally.
  7. This is not the first time I've seen this, but I think it's the first time I ever brought it up: I am using UTC to a data table to date/time-stamp an hourly production output. On my first sample, the UTC returned: 3724498800 I used this formula to convert it in Excel: =(F24/86400)+DATE(1900,1,1) where F24 contains the UTC value. This produced a result, after formatting, of 1/8/18 3:00 PM Which would be great - except today is 1/9/18 Simple enough to correct for with DATE(1900,1,2), but the inaccuracy is concerning. Am I doing something incorrectly? Edit: PS, I checked the Real Time Clock from Info Mode and it is correct. Thanks! TM
  8. What is the difference between the V100-17-ET1 ethernet card and the V100-17-ET2 ethernet card, electrically and functionally? I have several of the older cards I've kept from replaced / decommissioned PLCs and can't seem to find a difference in the specs. Thanks! TM
  9. Hi All! Ever since the birth of the V700, I sometimes pop my head in here, hoping to see a new V570-compatible ethernet module with support for seven sockets. I wonder if such a thing would be possible? I don't want to have to change the hardware, some of the HMIs are way too intricate... Thanks! TM
  10. The latest Visilogic, in addition to having full-width ladder nets, has ZOOM ON THE V1210 HMI DESIGNER! Thankyouthankyouthankyouthankyou
  11. In general, I also avoid this, but on the other hand, I like to keep reasonably current. This was the last project under 9.3.0, so upgrading it also eliminated a version from Swapper. The transition went smoothly enough, only one major hiccup. I had a Modbus TCP PHR function block that was writing to memory address 0x402 in the target device, and it spontaneously changed to decimal "4" out of the blue. I corrected it, and communication was restored. The peculiar thing is, there are two of these FB in the program, but only one was "mutated". On a side note, we also have an AB SLC running on their OS version 307, and programming in RS Logix 500 version 7. We never upgraded because we have never needed to, and still don't - only two of these in the building. We needed to get some spare parts, so I contacted our local vendor, and they informed us we would have to purchase the spare processor with the latest firmware (around $2k for 1 card!) and our RSLogix would not support it, so we would need to buy that too ($2500 more!). Of course, we could always sign up for a Tech Connect contract that we would never use, but includes software upgrades, etc etc etc. Just one more reason I love Unitronics - we could actually have this discussion about whether or not to update. With Rockwell, it's forced on you, a planned-obsolescence money-making scheme... grrrrr,,,
  12. Hi guys, I have an older project on a V570 that needs replaced. It's a very intricate project with alot of Modbus TCP and lots of CanOpen communications. I'm trying to upgrade to the latest OS first, but if I run into any issues, I'd like to clone the project from the original V570, along with the older OS, and restore it into the new unit. I was wondering if this is a viable approach, and if there are any "gotchas" I should watch for. Edit: The original is programmed in Visilogic 9.3, the new one is 9.8.9. Thanks! TM
  13. Well, that was less painful than I thought.I installed the wireless USB adapter and it appeared in the network manager as "Wireless Adapter 4". It has it's own listing in the Windows 7 wifi manager, and can select every network independently.So for laughs, I left my laptop wifi on "PlantWifi" and selected one of my machine networks, and boom - I was in. Well, not quite boom, it's fairly slow, but it worked. I used my phone to remote to the laptop and was able to manipulate everything. On top of that, I could still reach the internet and get email.For my next trick, I'll set up some wireless profiles with fixed IP addresses and see if that improves the speed any.
  14. Greetings all, Not strictly a Visilogic question, but related. Like a lot of facilities, ours has a plant-wide wifi connection for internet access on the floor, etc. And like a lot of people, I am using wifi to connect to my equipment for programming and troublshooting. Each of my machines has it's own wireless router, so connecting is as simple as changing my wifi connection from SSID "PlantWifi" to "Mill5", and I can connect without cables or opening doors. Now I've got a new challenge - I need to be able to remote into my laptop to help maintenance troubleshoot if I am not in the building. I can remote into my laptop as long as it is on "PlantWifi", but lose my connection once I tie into "Mill5" (no internet to the machines) So my thought was to bind my laptop internal adapter to "PlantWifi" for remoting, then use a second USB wireless adapter to connect to "Mill5". Turns out this is a lot more challenging than I thought it would be. Windows 7 wants to route everything across one or the other, and it seems there is little control for this. Options I've considered - 1. IP filtering in the laptop - the machine networks have a small range of IPs in common within their own setups, so force traffic with that IP across the USB nic. 2. Sandboxing or a virtual machine to allow Visilogic access to only see the USB nic, but that seems like a lot of overhead. 3. Been seeing programs online like ForceBind, but apparently that would somehow hack Visilogic (insert hooks, they call it) to restrict it to the USB nic, not very comfortable with that idea. Also, these utilities all seem pretty old and unmaintained. For the record, connecting them all to factory LAN is not an option. So my question is, has anybody here done something like this? And if so, what did you use to pull it off? Thanks, TM
  15. But I still use Visilogic, and I'm not as young as I used to be, so please please please consider adding zoom functionality to the HMI designer for the V1210? I can't tell if my screen elements are lining up anymore. And it's tricky using a wooden ruler and masking tape on my computer screen. Thanks, TM
×