Jump to content

Abomination1

Members
  • Content count

    6
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Abomination1

  • Rank
    Newbie
  1. Hello; do everyone know, can on V350 someone run this - > http://www.murrelektronik.com/fileadmin/USERDATA/Downloads/English/Manuals/55364_hdb_e_16.pdf This is Profibus 16x DI module. What do i need and how can i configure it? Can i run it, or is need to change the protocol? Best Regards
  2. Hello! I dont find enywhere; if unitronics macros for Eplan p8 even exist? I need Jazz, and all visilogic macros for Eplan. On "main" unitronics website i dont find it. Does macros even exsist??
  3. I just finishing with test on my PLC with shaft encoder. I've tested shaft encoder on input 2,3 (HSC 2,3)... and auto reload at difrend values. Then i turn my shaft 20x - 20 circuits. my result are here: CLICK Like u see in linearizacion I make difrend values. when i make 360-1440 value and reset at 1436, then PLC count OK. But after 20 circuits i have 15° (must be 0°). Why is this shift? If i make defalut value (360...1440) and reset at 1440....then like you se, PLC count wrong (359°, 360°, 0°, 1°...) but after 20 circuits, i have again 15° error. I make this test for each value twice. So values should be right.
  4. Yes I configure HSI + reload (Enable Reload is always "1" - power up value SET - "1"). This function automatic reset value at 1440 (predefine value). In this case I dont define interrupt. This dont work for me neither. PLC again "missing" counts. Then i configure HSI + reload, but without power up value in Enable Reload (now can I reset value within _Interrupt). Then configure _Interrupt HSC 2,3. When couter value is at 1440 interrupt appears. In interrupt is one coil. This coil "activate" Reload Event and reset counter value. This dont work - again missing counts. This are result from oscilloscope. On first picture are A and B signal. On second picture are B and index/z signal. All looks great. First picture cLICK Second picture CLICK -- I dont know why i cant add pictures to the forum - Invalid image extension. I've try *bitmap and *jpg.
  5. HELLO! Nothing work for me sry =( I just try with interrupt at HSC 2,3. Reload value is set at 1440 (x4). PLC reset counter when is 1440..all is fine there. Interrupt works fine. PROBLEM: 1. Start PLC. Shaft is at 0° (reset value). 2. Shaft encoder slowly turns at 380°. 3. Slowly get to 360°+ ...0...1...2...3...°.. Interrupt works fine. but if i turn faster shaft encoder around 360°(0°)... ERROR again appears. If i by hand turn my encoder a litle bit faster, then, after 10 circles, i got, at 0° -> value 355° or 5°... ITS NOT ZERO... I've tried it all, do not know what else to do... So this "error" appears if turn my shaft encoder fast over the 360° (when interrupt appears)..what is wrong? bdw; i try reset value in lader with index/z signal...It works great (ofc at very low hand speed - problem with sensing index signal)
  6. HELLO; I have V350-35-T2 PLC controler. At imput 3&4 (input I2 & I3) is shaft encoder (signal A and signal B from shaft encoder). Shaft encoder value is defined in program and this value decreas and increase, depends on witch way, shaft encoder turn. Reset shaft encoder value is in software at 360° (1440 - x4). With this value i can count turns + i have control over angle. frequency (max.) for this PLC is 20kHz (at 10m of cable, i have 5m of it). My first question is, if frequncy is halfed (10kHz) becuz I use channel A and ? I can then use only 10kHz? Problem occures at 100RPM (its the lowest RPM of motor) width subtract angle. When first 360° is over at my PLC i see 359, 358,357..depending on speed of motor. Moore time shaft is turning the lowest is number. The error is integreated over the time period. So at 30 turns i have left only with around 330° (depends what speed I use - arround 120 RPM). Shaft encoder have 360 PPR and he is at 100RPM...This is 600Hz. I dont get it, why 600Hz is to fast for my PLC. I configure input 2 & 3 as shaft encoder (x4) + reload. Reload accure at 360° rt at 1440°(cuz number is multiplayed x 4) (at full circle). This shaft is mounted on mashine. This mashine create one product in 360° and stoped at exactly 360° (0°) -> full circle. its seems that shaft encoderis is not able so quickly read angle? But i dont geet it - shaft encoder is high speed encoder for max speed 6000 RPM. Maybe there is something wrong with input of PLC? I configure it as shaft encoder etc... Shoud i wrote PLC program in 2.5 mS interrupt? My program have just 3 lines of code (linearization, counting pulzes, reset at 360°). That's it. Should i use immediate function blocks? Can i use them in "normal" program, or they must be in interrupt, otherwise they will not work properly? thx for the answers Best regards Dejan Rožič
×