Jump to content

Gugulanov

Members
  • Content Count

    34
  • Joined

  • Last visited

  • Days Won

    1

Gugulanov last won the day on July 22 2015

Gugulanov had the most liked content!

Community Reputation

2 Neutral

About Gugulanov

  • Rank
    Advanced Member

Profile Information

  • Gender
    Male

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hi all, After some work on my project (last I changed web-server pages), I have constant crash at the end of compiling. It's Unilogic 1_23_25 on Win7 32bit. I installed 1_25_54, but it's same there. Here is what I get: Original solution path: C:\Ver 1_23_25\Ima1 v5 23_VNC.ulpr <<System.Collections.Generic.KeyNotFoundException>> from <<mscorlib>> The given key was not present in the dictionary. -------------------------- { "ClassName": "System.Collections.Generic.KeyNotFoundException", "Message": "The given key was not present in the dictionary.", "Data": null, "InnerException": null, "HelpURL": null, "StackTraceString": " at System.Collections.Generic.Dictionary`2.get_Item(TKey key)\r\n at Unitronics.WebServer.Compiler.WebServerCompiler.createUniData(String path, Func`2 checksumCalc)\r\n at Unitronics.WebServer.Compiler.WebServerCompiler.Compile(String path, String appName, Func`2 checksumCalc, Boolean isCompileForDownload)\r\n at Unitronics.WebServer.Solution_Explorer.SE_Main.Compile(String path, String appName, Func`2 checksumCalc, Boolean isCompileForDownload)\r\n at Unitronics.SystemServices.CompilerServices.Compile(IEnumerable`1 featuresList, CancellationToken ct, Boolean produceScriptedDB, Boolean withMedia, Boolean isCompileForDownload, StateChangedDelegate stateChangedDelegate)\r\n at Unitronics.Shell.UI.RibbonTelerik.UI.ViewModels.RibbonViewModel.<>c__DisplayClass400_0.<downloadCompileCurrentSolution>b__0()\r\n at System.Threading.Tasks.Task.InnerInvoke()\r\n at System.Threading.Tasks.Task.Execute()", "RemoteStackTraceString": null, "RemoteStackIndex": 0, "ExceptionMethod": "8\nget_Item\nmscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089\nSystem.Collections.Generic.Dictionary`2\nTValue get_Item(TKey)", "HResult": -2146232969, "Source": "mscorlib", "WatsonBuckets": null } Any ideas? Regards
  2. Hello, I was unable to export from one project and import to another project I/O tags. Gives me "Import Failed" - Tags in row # type not valid. It's Unilogic 1.18.41 Are there some tricky conditions to be fulfilled first? Regards
  3. Hi, What is the reason for difference between timestamp "last modified" of file written on SD-card, and the PLC time when this file has been saved? I have 3 hours difference between them. (I connect to PLC with FileZilla ftp client)
  4. So, I installed the last version 1.17.73. The problem with Web-server that I had described, is not present now. Concerning FTP, meanwhile I changed my application in order to use some TCP transfer, instead FTP, and now I can't inform you if there is positive change. Thank you for advises and support ! Best regards
  5. Yes, they are retained tags. Is this a problem? Regards
  6. Hi all, What could be the reason for this behavior: - web server don't refresh all of variables and elements; the real values appears, when I connect VNC client to the plc and go to the HMI screen, showing the corresponding variables (I think that going online with Unilogic 1.17.58, also helps). - FTP file transfer between two plc's in some moment freeze; going online and viewing the FTP server struct somehow fix the transfer. Could the reason be a large applications in the two plc's (70-80%), that I'm using, and the many communications in projects (CANbus, TCP , FTP)? I'm not sure, but in previous version of Unilogic I didn't noticed such problems. Regards
  7. Hi, Just for info, it's not connected directly with the topic, but is connected with saving of table into file. If I'm not wrong, my observation is, that when if there is a saved DT file once, if you meanwhile change the table struct, and try to save (in my case with overwright), status of "Store DTI to file" function gives error code. Deleting the old file helps, and further saves are OK. It's not a big issue, but someone may wonder what's hapening. Regards.
  8. Ahaaaaa.... I see. No more questions on this topic. Regards
  9. Hi, It will be very useful indeed, Unilogic to have some project Memory Map (like VisiLogic), in order user to have control of used memory in application that he build. In my case, I reached the moment, when I received the message for full memory, and I must reconstruct many things in order to fit in limitation. If I had this Memory Map before, I could develop things more cleverly. Regards.
  10. OK, I'm glad, that I'm helpful in some way and thank you for the support. Regards
  11. Hi Meanwhile, I think that I managed to remove the problem. Deleting the data table widget and creating it again fix this disappearing of the tag. BUT, What is the story: - I'm writing projects for 2 panels. The projects will have a number of same screens. - from project for first panel I make "Add to library" of 6-7 HMI screens, all with data tables in them, in order to save time and work. - in project for second panel I import these screens from library. - in all these imported screens I had the same bug - missing tag for selected row. Now I'll re-create all tables in second panel's project, in order to fix the things. You can check if there is really bug in import/export function to library in Unilogic software. Regards
  12. Thanks for quick answers! About the data table, I noticed something strange. When I open the saved project with "Tag:Selected Row" field empty (which had been linked with tag before "Save"), while performing "Find" for this tag, in results this tag is part of the Data Table object in the HMI screen, but in fact the field in properties is "Empty" . This happens with all HMI tables in the project. I tried to replace the tag with new, as you propose, but without luck - same thing. Regards
  13. Hi all, What is the meaning of "pen icon" appearing in ladder and HMI sections in solution explorer? Because, I save the project - all pen icons disappears, quit Unilogic, start Unilogic, open the same project, and the again I have these "pen icons". Similar issue is: in the same project I have HMI with data table visualisation. In the properties window I have chosen the right table and tag for "Tag:Selected Row". I save the project, guit Unilogic, start Unilogic, open the same project, and "Tag:Selected Row" is empty. Any ideas for this strange behavior, and aren't the two issues connected? Regards
  14. Do you have a plan to include option for configurable ports in future versions of Unilogic?
×
×
  • Create New...