Jump to content

marcunni24

Members
  • Content Count

    2
  • Joined

  • Last visited

Community Reputation

0 Neutral

About marcunni24

  • Rank
    Newbie
  1. Gabriel, Thanks for your prompt response. I've added the delay, and now it's working properly. Regards Martin
  2. Dear all, I'm programming an application on a SM43-J-R20 PLC+HMI. I've added a V100-17-RS4X card, in order to use RS485. I've succesfully implemented Modbus RTU communication with a Frequency Drive. The thing is, I need to communicate with 11 of them. The ladder logic so far uses the Modbus function blocks, as can be seen on the Modbus webinars on Unitronics page. That is, I SET a variable (ex:MB0) , which is used for enabling the "function 06 Modbus" block (preset holding register). At the output of the block, I RESET that same variable, ensuring the block gets executed. At the same time I reset MB0, I SET a new variable (MB1), which in turn is used for enabling the second Modbus block. This creates a sort of "continuous broadcast" to the drivers (which, If they don't receive a command in a certain time, trigger a failure). When the last block gets executed, the sequence restarts, The question is, when I try to send a Stop command to one driver (for example), it takes an awful amount of time to execute the order (30 seconds or so). I believe I may have a conflict between some of this blocks being executed at the same time. Is there a tutorial or an example where I can see how to succesfully implement Modbus communication with several slaves at the same time? Thanks for the support. Kind regards, Martin
×
×
  • Create New...