Jump to content

Santiago Fernández

Members
  • Content Count

    3
  • Joined

  • Last visited

Community Reputation

0 Neutral

About Santiago Fernández

  • Rank
    Newbie
  1. I'm trying to configure a connection with Azure IoT Hub using the MQTT protocol with no luck. I need to configure the broker using the 8883 TCP/SSL with CA Certificate. I provide the correct certificate of the root CA but I always get the -1 status code (Cannot connect to broker. Check communication parameters) in the broker. I checked all the communication parameters and tested with a MQTT client (MQTT.fx) and I was able to connect correctly to the Azure IoT Hub. At this point my question is, is there any way of getting more information about which communication parameter is failing or getting more information for troubleshooting? Thanks in advance
  2. Santiago Fernández

    We want to know!

    Hi Rivka, Those are excelent news. The point with the password is that Microsoft uses a SAS token for authenticating the client. This token exceeds the 128 characters. In my case my token is 139 characters long, so I think that this new limit of 255 character for the MQTT password is more than enough. Regarding the authentication using client certificates is also a real good news. It will add a good value for our projects. Thanks for the update Rivka!!
  3. Santiago Fernández

    We want to know!

    I've been investigating a little bit more about MQTT with Azure and I'd like to share my findings with you. The problem with the connection is the limit in the password field (128). Azure requires a SAS token for authentication that requires much more than 128 characters. The other option for authenticating to Azure IoT Hub (MQTT) is using a x.509 client certificate. That authentication option is neither supported by UniStream 5 MQTT implementation. My question is: would be possible to extend the password field limit? I'm assuming that implementing client certificate authentication is much more complex.
×