Jump to content

Rookie

Members
  • Content Count

    3
  • Joined

  • Last visited

Everything posted by Rookie

  1. Funny story, true story. It turns out that a mini usb cable has 2 different cable types. A data cable, and a power only cable. I had the latter... Bought a data cable and it connected no problem. Thank you for the help!
  2. Hello, I am struggling to understand Visilogic's MODBUS tools. Say I would like to turn a light on and off from the master PLC, while the output is attached to the slave PLC. What would be the best function block to do this? I keep using the FB #5 and I will get the bits set high, but then they will stay high. I am practicing so I can use PTO utilities to control steppers instead of lights. First, I need assistance in understanding why things like MODBUS FB (5) sets and doesn't reset. The attachments are just HMI lights telling you if you get the commands from the Master PLC. (You get them only if the 2 bits begin in RESET using the online mode) Otherwise, O5 in the picture is the LED I am trying to turn off and on from the master. Thank you! MASTER MODBUS TEST.vlp SLAVE MODBUS TEST.vlp
  3. Hello everyone, I'm a beginner to using PLC's and I'm having some trouble connecting to my PLC. I don't know if my PLC is bad, cable is bad (pretty sure its good), or my ports are messed up. I have no experience and I am using the U90 ladder program. In U90, when I go to Controller>Operating System or the 2nd way I've been going about it Controller>M90 OPLC Settings, I am just trying to establish connection to my computer to the PLC. I keep getting errors on failing to connect to the COM port. There is another post on here talking about how my PLC (JZ20-R31) has a USB mini port on the side. I have the driver for it downloaded as well as the driver that comes with the 'Install Driver' button in U90. I've never really messed around with ports before, so I'm not sure what I'm supposed to be looking for. Some other online stuff said to try Device manager>Add legacy Hardware> .... Could the issue be not choosing the right options after I choose "Ports COM & LPT "? Because no matter what driver I do, I can confirm that the COM# in Device manager matches the one in U90 ladder and I still can't get the connection. I have a windows 10, HP Pavillion 17 notebook. Can you provide any tips for a rookie?
×
×
  • Create New...