Jump to content

Search the Community

Showing results for tags 'ascii'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Our Community
    • Come on in!
  • News and Announcements
    • Latest Release! UniLogic V1.28 introduces Motion: Servos & Motors plus OPC UA server!
    • VisiLogic:9.8.64 - Link to mobile app, Ladder: 2x the Space!
    • New!!! ***** U90 Ladder*****
  • UniStream HMI + PLC Programmable Controllers & UniLogic Software
    • UniStream: Hardware
    • UniLogic Software
    • UniLogic UDFBs
    • Industry 4.0, IioT, MQTT, OPC UA
  • Vision, Samba, Jazz and M90 PLC + HMIs & Software
    • Vision & Samba PLC + HMI Controllers & VisiLogic Software
    • Jazz, M91 PLCs and U90Ladder
  • Software Utilities
    • SD Card Suite
    • Remote Operator
    • Remote Access
    • DataXport and DataXls
    • UniDownloader
    • UniOPC
    • UniDDE
  • Utilities for .net and Visual Studio
    • Unitronics PCOM Protocol
    • COM Object ActiveX .dll
    • .NET driver
  • Project Design
    • ...I have a project...what hardware do I need?
  • User Application Stories
    • Just finished a great project?
  • Tips and Tricks
    • Best Programming Practices
    • Tips and Tricks
  • Job Board
    • Projects seeking Programmers
    • Programmers seeking Projects
  • General Discussion
    • We're Listening...
    • The Lounge
  • News and Announcements Copy

Calendars

  • Community Calendar

Blogs

  • Unitronics' Blog: PLCs, HMIs and more
  • Saragani's Blog
  • Simon's Blog
  • Ash Neilson's Blog
  • Joe Tauser's Blog
  • Unitronics en Español
  • Powered by AMPS
  • Alldrives UK's Blog
  • Unitronics, Howman Style
  • PLCNewbie's Blog
  • Telestar Automation Blog
  • Webinars Collection
  • Tim's Corner
  • Blog
  • TELESTAR (Italian)
  • i4 Automation
  • i4 Automation (UK)
  • Unistream UDFB's

Categories

  • From Headquarters: Sample Applications
    • From Headquarters: VisiLogic
    • From Unitronics: U90 Ladder applications
  • User-submitted Applications
    • From Users: VisiLogic applications
    • From Users: U90 Applications

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Categories

  • New Features
  • Other

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

Found 7 results

  1. I have an Ohaus scale with a serial printer port connected to a Unistream 5" pro. A part is place on scale and a comparison is made to a valid weight range. I finally have a working model for getting weight ASCII string into a REAL but it's very clunky. There has to be a better way. The biggest issue with my conversion rung (before using mul & add FB's) is if I weight in a part at 10.39 grams and the REAL displays as such and the next weight is 7.43 grams (THE TENS PLACE IS A NULL ((BLANK)) CHARACTER) the real displays as 0.43 grams. The tenths and hundredths always read out okay because the zeros present regardless of fractional weight. Is there a cleaner way to take " 10.39 g" ASCII, narrow to "10.39" ASCII and convert to REAL D#10.39? Next issue, I want the buzzer (more of a beeper) to sound for a short burst when a valid weight is received. In Vision there was a simple SB bit that would sound buzzer for any duration the OTE was true. I have tried several constructs with the BUZZER START AND BUZZER STOP actions but always end up with a continuous buzzer or a chatter. Please and thank you for any assistance. Please see "WEIGH IN" subroutine for example of the code I have that works but could stand to be simpler. JorachoPressNewScale12-20-18e.ulpr
  2. I have inherited a project from an engineer who is no longer with my company. The system is a Vision120 communicating to a pc running windows 95. I am tasked with understanding this older system and start to implement updates. I have figured out 99% of the program and communications that is happening with the PC but there is one Command sent to the Vision 120 from the PC that I don't understand what it is for. PC: /00IDED. PLC: /A00IDVUN2A4500153. The ID Command is not covered in the standard PCOM manual. Is there a more thorough PCOM Manual Some Where? Thank you for any assistance.
  3. Hello, In my program I receive a length of vectors on MI120 - MI143. When I use ASCII string to display all the vector in one line on the HMI, I only get the first character which is inside MI120, even when the length is very long. When I put RTC to vector, it is possible to display it with the samen function. So for example: MI120 a MI121 b MI122 c I want to see: abc, but I only get a. How can I solve this? Thanks!
  4. Hello! First of all let me say that I am a beginner with unitronics PLCs but so far I am quite happy with them! Now, about the topic. I have programmed a Vision 430 to send E-mails and would like to add some information on the content of the e-mail. This is easy using the "indirect mail content" option, however I need to build the text depending on different cases, so I am trying to use a section of MI's to do so. However when the a-mail arrives all the text apears to be in the same line. I tryed inserting a String with a Line Feed in the MI's linked to the mail content but it doesnt seem to work and all the text that follows is not sent, I belive maybe it is being taken as a Null Character. So, does anyone know how to add Line Feeds direcctly to the MI's or the indirect email content. I hope my question is clear since english is not my first language, sorry for any mistakes!
  5. I'm working with getting names from a DT on the screen, and I got the folowing: read name from dt, row offset in string1 read name from dt, row offset +1 in string2 .... read name from dt, row offset +14 in string15 next page = offset + 15 reload. This way i can skip through the DT and show all values, but now I got a strung with 15 times almost the same code. The problem is that there isn't a array[string] with which it would be possible to make a loop. If there would be an array[string] then i could save at position [offset] and next time [offset +1], but now i need another name thereby I't isn't possible to make a loop. Any ideas?
  6. Good evening I have written a program for a barcode scanner that reads a barcode and parses the info to the screen, and then communicates it to a printer I do however have a couple of issues 1) If I plug the scanner into the port of the V120 it doesnt work, however I think that must just be me, as I downloaded a program called termite and plugged in the PLC to one port and the scanner to another, set my ports to forward in the program from the scanner to the PLC and it works. The major problems that I am facing is that unless I switch screens the HMI does not update, cant work out how to do that.. any thoughts The next problem is that if the first barcode I scan is 20 characters long and the next is 15 then the last 5 characters do not clear out, but stay with the new scan, this I dont understand so if anyone has some ideas I would love to hear them Thanks
  7. Hello everyone, I have two devices on the same RS485 line: one is a standart MODBUS RTU device, the second uses its own protocol in ASCII code. COM2 is configured to 9600 n 8 1 and I use positive pulses with 1 sec timing to activate Protocol Configuration FB and MODBUS Configuraton FB. The cycle starts with the ASCII device, then after getting the reponse I switch to MODBUS and get the required data, but when I switch back to the first ASCII device, even though OPLC sends the data, I receive no response. If I try to send the same data again, I get the response and proceed to MODBUS request and so on and so on, but the fist ASCII request after MODBUS gets no response, while the second request straightaway gets the data. Both the device work perfectly well independently, and I have tested the above described cycle both automatically and manually, so I am pretty sure it is not a timing issue. Would anyone kindly advise me on the situation? Is it an OPLC issue (something to do with buffer clearing in Modbus mode) or maybe it is a Modbus slave issue (ie commnication ports dont close or else)? Unfortunately I am not that good with Modbus yet, and googling the problem didnt help.
×
×
  • Create New...