Search the Community

Showing results for tags 'jazz'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • News and Announcements
    • Welcome to the Unitronics User Forums
    • New!
    • VisiLogic: Major HMI Image Library, New 7" Samba!
    • New!!! ***** U90 Ladder*****
  • OPLCs and Application Software
    • Vision PLC series and VisiLogic
    • Jazz, M91 PLCs and U90Ladder
  • UniStream HMI + PLC and UniLogic
    • UniStream: Hardware
    • UniLogic Software
    • UniLogic UDFBs
  • Software Utilities
    • SD Card Suite
    • Remote Operator
    • Remote Access
    • DataXport and DataXls
    • UniDownloader
    • UniOPC
    • UniDDE
  • Utilities for .net and Visual Studio
    • Unitronics PCOM Protocol
    • COM Object ActiveX .dll
    • .NET driver
  • Project Design
    • ...I have a project...what hardware do I need?
  • User Application Stories
    • Just finished a great project?
  • Tips and Tricks
    • Best Programming Practices
    • Tips and Tricks
  • Job Board
    • Projects seeking Programmers
    • Programmers seeking Projects
  • General Discussion
    • We're Listening...
    • The Lounge

Calendars

  • Community Calendar

Blogs

  • Simon's Blog
  • Ash Neilson's Blog
  • Unitronics' Blog: PLCs, HMIs and more
  • Saragani's Blog
  • Joe Tauser's Blog
  • Unitronics en Español
  • Powered by AMPS
  • Alldrives UK's Blog
  • Unitronics, Howman Style
  • PLCNewbie's Blog
  • Telestar Automation Blog
  • Webinars Collection
  • Tim's Corner
  • Blog
  • TELESTAR (Italian)
  • i4 Automation
  • i4 Automation (UK)
  • Unistream UDFB's

Categories

  • From Headquarters: Sample Applications
    • From Headquarters: VisiLogic
    • From Unitronics: U90 Ladder applications
  • User-submitted Applications
    • From Users: VisiLogic applications
    • From Users: U90 Applications

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Categories

  • New Features
  • Other

Found 29 results

  1. Hi, I have Jazz PLC JZ20-J-T40, and i have 6 Screens on it. I have downloaded my program successfully, and PLC has been working properly for a wery long time, (two months to be exact). After I turned OFF and ON my PLC, it didn't displayed screens I have on it, so I thought that I have burned it, because of power or something. I measured power supply, it was OK, so I connected Laptop to PLC. I have successfully conected to PLC, and went online. I have some MBs on plc that i change using plc tasters, tried that, it works just fine. Everything works properly, except PLC Display. U90 Ladder has an option to debug display online, so I tried that on my laptop, it shows displays as it should, but on PLC just blank screen. I can see that PLC display is glowing a little, it just doesen't show any text that it should show. I have tried to download again, nothing changed. I tried to update Operating System, it says it's up to date. Is there a way of fixing this? Best Regards, Nikola Ljubinkovic
  2. Hi, I have Unitronics PLC V130-J-TR20 PLC, which is a master, and two Jazz JZ20-J-T40, which are slaves. I need two of the slave Jazz PLC's to communicate with master V130 PLC. I have made configuration in PLC Program for read and write, but it's not working properly. When i set bit for request to read PLC3 (MB100), it reads it normally. But, when i try to read PLC2, it reads same value that I have on PLC3, although Communication is OK with PLC2. I have read example project, and used it to configure communication between PLC's, like you can see in the images. Regardless of what I do, one of the PLC's is not working properly, communication says it's OK, but keeps reading values from other PLC. IP addresses are different, of course, and i have typed them correctly into the MODBUS IP Configuration, like in the image. On my Jazz PLC's I have done everything like Example project in U90 Ladder says. Is there a way of fixing this? Thankful Nikola Ljubinkovic
  3. opc

    Hi, I have two Jazz JZ20-J-T40 PLC-s, and one V130-J-TR20 PLC. I am using zView SCADA. I tried to connect them via Ethernet by using switch, but I cannot use two different PLCs on this SCADA. Then i tried to connect them to SCADA via uniOPC, but communicating is just too slow. I have just one bit that goes from 0 to 1 in 0.5 seconds, and back to 0 in 0.5 (1 second pulse), just for testing, still it's too slow. It runs normally for like 2,5 seconds, and then just stops, and changes in 4-10 seconds, or just freezes for 2-3 minutes, and then changes. My PC Spec are not in the way of this, I am sure of that, i have tried it on my weakest and strongest laptop, still exactly the same results, too slow with just one bit for each of the PLCs, that is 3 bits total. Does anyone had the same problem, is there a way of fixing this? Regards Nikola Ljubinkovic
  4. Hi, I'm using Unitronics PLC JZ20-J-T40, and ZView SCADA. I have successfully downloaded my program into PLC, and tested communication via usb (Serial), and via Ethernet (MJ20-ET1). It's all working properly. Problem begins when i try to connect my PLC to scada PC. With USB everything is working normally, but it's not an option for me to work with usb connection. I want to work with Ethernet communication between PLC and SCADA. What should i do to make it work? Regards Nikola Ljubinkovic
  5. Hi, I'm learning ladder by the aid of Unitronics JZ10-11-R10 PLC. While writing my 1st program I've ran into issue. The thing is that I can not find a way to input MB value from HMI. Are there any ways to do it ? Thank You
  6. Hello, I have a Jazz JZ20-T40 controller and i accidentally reversed polarity on transistor output power supply. Now that set of outputs doesn't seem to work (O0 - O11). Is there any fuse or something that i can change or is it necessary to take it to service to fix this? Thank you and best regards, Pawks
  7. Hello, I have JAZZ JZ20-T40 controller with two groups of transistor outputs, each with its own power supply (o0-o11 and o12-o19). Now my question is, can i power one group of outputs with 24VDC and the other with 12VDC? Or is 12VDC not an option for output power supply with this JAZZ at all? Thank you, Best regards, Pawks
  8. Hello, I have a problem using MODBUS communication with JAZZ JZ20-R31. I have two slave devices connected. I just read from the first one, and i just write to the second one. I had the first one alone before i added the second one and communication worked just fine. Problems came when i added the second device (the second one is a PLC from another company and it's used to send written data to the web). Yesterday communication worked for a few cycles, but after that it completely stopped, even with first device - there were no LED lights blinking like it should. Today i restarted my main JAZZ and talked to the guy behind the second device. He says that he sees the RS485 communication and that i am writing data to his device three times in one second. My MODBUS is setup with timeout set to 3000msec and 1 retry. I checked my write function, but it is only called once a minute (roughly) as i intended at the beginning. otherwise i have MODBUS commands separated by steps of 4 seconds each, so one command can't interfere with another. I tried to increase step times, changing timeout and retry on MODBUS setup, sending data in multiple steps, but nothing seems to help. What could be the problem here, i ran out of ideas...? Thank you, Best regards, Pawks
  9. Hello, Is there a possibility to update jazz firmware via modbus? By that i mean to read data via modbus and then execute the update. Or is the only possibility to manualy update with u90ladder? Thanks, Pawks
  10. Hello, I'm using Jazz JZ20-R31 controller together with MJ20-RS add-on module for RS485 communication. Is there a way to use RS485 communication and simultaneously use a modem on RS232? To rephrase the question: I would like to achieve some sort of remote access to data while still communicating via RS485, are there any suitable options (modem, wifi...) ? Thank you, Best regards, Pawks
  11. Hello, I have a problem using analog voltage inputs (0 - 10V) with jazz. When i connect one input (AN2 for example), the other input (AN3) also reads voltage which depends on AN2 input. It's not the same value, but if AN3 is not connected, voltage read is about 80% of what AN2 reads. When both inputs are connected, one affects the other and vice versa... It's really significant effect, so i don't think it could be interference related. Both inputs are also from the same power source and grounded. Any ideas what could be wrong? Thank you for help Best regards, Pawks EDIT: I forgot to ground pin "n/p I16-I17", now it works fine. Sorry for that.
  12. Hi I have an 3 installations. Each consisting of 8 x Jazz UA24, 2 x M91 RA22, 1 x JAZZ R16, 1 x JAZZ T41, 4 x CIAT water Chillers 2 x PROCON analogue input modules. They are all networked on RS485 using Specview SCADA package as MODBUS master. All the Jazz PLCs use the JZ-RS4 com port adapter All the Jazz controllers use the same Communication setup nets All the Jazz controllers are run from the same 24VDC power supply So that's the situation as it stands. My problem is that the JAZZ R16 on all sites has very flakey coms. It will occasionally come online after a restart for a short period of time then fall off again. The comms on all the other devices including all the other JAZZ PLCs is pretty solid. I have tried downloading the exact same program into a spare jazz UA24 and it communicates fine. So by deduction I would assume it is a hardware issue with the R16 specifically. Has anyone else had this problem and is there a way to fix it?? Thanks
  13. Hi all, Is there a way to measure power factor of a three-phase generator with jazz plc (JZ20-R31). I have an option to use an existing device(Sentron pac3100), but only float data type avaliable. Another option is Elnet which has integer data avaliable, but integer 0 when PF is 0,85 doesnt really help... I probably could get it with some math functions between real and apparent power, but that isn't the most elegant way to do it and is also error prone. Is there another way with JAZZ or do i have to use a different controller? Thanks in advance, Best regards, Pawks
  14. Hi evrybody I have problem with my Jazz PLC (JZ20-T18) If i plug usb conector my computer recognize "Unknow device" I try to install driver from U90, but no effect I also turn off UAC and install driver as admin I don't now where is the problem Can somebody help ?
  15. Hi, I'm using U90Ladder and jazz JZ20-R31. Everything was fine for a while - i was uploading and downloading projects with no problem and everything worked fine. Until suddenly when i tried to download a project i was asked for a password. (PLC is locked! Please enter password..) I never enabled any password protection, and never before was asked to enter it...where did this come from? I have no idea what is the password or how to unlock it now? What to do? Thank you, regards, Pawks
  16. I need to establish communication betwwen jazz (master) and energy analyzer-klea as slave using RS-485. Model of jazz is JZ10-11-UA24 with MJ20-RS. I need to read float value in klea starting addres 0 (Average voltage of three phases) I am newbie with unitronics and modbus ... Tnx in advance for any help. In attached files are: 1-klea modbus function 2-data adress in klea 3-example in klea
  17. Hi All, I have 3 Jazz PLC's communicating over Modbus with JZ-RS4, 1 master (R31) and 2 slaves(R10). Is there a way to check for errors in comms, Rx & TX. If comms fail, to reset all outputs on both slaves. (similar to CanBus "check alive function") thanks Matt
  18. Hello Can you give me an advice how to solve the problem.Well,I have PLC Jazz 20 R31 connected to modem(Scada) by RS485(Modbus protocol). Everything works but from time to time the communication between the devices disappears and I have to reset the PLC If I wanna restore the communication. It happens often when some unit(pumps) is switched on. The file with my Modbus config is attached How to solve the problem? Sincerely Wladimir unitronics.U90
  19. Hello! I would like to use my PLC controller to my study project. I have the Jazz JZ20-R10. I want to connect PLC to my PC. The reason of this connection is not download program from 'U90 Ladder', but i have identified mathematical model of process (steam boiler) and I need simulate this process on my PC. I have transfer function, differential equations. To recieve analog output values i'll use Euler method. This mathematical model with simply visualization i'm going to make in C#. And here is my problem. I nedd to send my output values from mathematical model in C# to memory (registers) Jazz. There, will be some LAD Program, and then JAZZ has to send values from registers to my computer (it will be my input of my mathematical model). Is it possible? Could You please give me proposals of solutions? Thx
  20. Hi everybody, Greetings to all, another newbie here... Having some issues on getting Modbus RTU messages to work on JAZZ PLC. My setup: 1) JZ20-R16 PLC with MJ20-PRG adapter (?) plugged in it. I'm using MJ20-CB200 cable (RJ11 plugs on both ends) and MJ10--22-CS10 adaptor (DB9 female connector). Using this gear I can query the PLC with modbus RTU messages over RS232 serial line. Serial line settings I use: 9600bps, 8(data bits), none(parity), 1(stop bits) 2) Gemalto modem (BGS5T) as a modbus master. It has DB9 female connector on it as well. 3) Serial to USB converter cable for serial communication verification. A bit of context: while using serial-to-usb cable I can't query PLC all the time. That means, *sometimes* I can query it successfully, but after disconnecting and messing around a bit I cannot query PLC any more. Unplugging USB-to-serial and reconnecting helps, so I assume it's kinda converter drivers/whatever issues so not a big deal here, just a note. So using this cable I can verify, that PLC *can* (though not always I would expect) respond to Modbus RTU messages properly using defined settings above. I have couple of Modbus master simulation programs and strangely enough only one of them can query the PLC successfully. Real problem: I have written peace of software for BGS5T to act as a modbus tcp/ip to modbus rtu gateway. I can verify that this gateway works by three methods: 1) run modbus slave simulator on a PC, connect gateway over serial line to PC (same usb-to-serial cable used here) and query PC slave simulator over that modem acting as a gateway. Everything's just fine. 2) I can connect to the terminal program on a PC and verify that sent message to serial line is valid modbus RTU message: 0x01 0x03 0x00 0x02 0x00 0x01 0x25 0xCA : (from left to right hexadecimal values) 1) device ID (1 byte) 2) function code (1 byte) 3) start address (2 bytes) 4) register count to read (2 bytes) 5) CRC (MSB) 6) CRC (LSB) 3) I have made "sniffing" rs232 cable and I can listen on messages being set to PLC or being received from PLC (depends on wire I'm hooking to). I can verify that exactly the message defined above is sent to PLC using serial settings mentioned above. PLC does not respond with anything. Absolute silence.... I used 3 wire connections (Tx, Rx, GND), used null-modem configuration for both modem and PLC, nothing helps. JAZZ PLC is silent for those messages. What could be wrong here? Voltage levels does not match..? handshaking is mandatory on JAZZ PLCs..? I'm completelly out of ideas to try out, cannot sleep normally over a week now... I don't know much details about serial line physical implementation, so feel unsure in this topic. Please help. Regards from LTU
  21. Hello everyone, we will have 2 new machines in our Company for textile processing. Both are controlled by a Jazz Unit. These 2 machines will have the same model no, but they have little differences in the handling from the software side. So we wanted to "copy" the "jazz Project" (Software) from one Jazz to the other. First surprise: One machine ist controlled by a Jazz model JZ10-11-T17 (only Serial port (optional)), the other one by a Jazz model JZ20-T18 (USB). So we asked the german Jazz Distributor, if this will work using the u90ladder Software. No Problem was the answer! Now we did it today and also upload from jz10-11-t17 and download to jz20-t18 worked FINE - without Errors in the u90ladder I mean. The only thing was, that I had to change the hardware configuration from the project for the older jazz to the new one to proceed download. Now we did it 2 times and also tried to download the "original" (backuped before) Project / program to the jz20-t18 But the jazz unit will only "boot" / start to the Information mode, also after power off and using Run? and Reset commands of the Information mode. The program for controlling textile processing is not starting! Display will Show only "Eingang (Entry) -> (i)". Press and hold < i > button then will show the Information mode - that's all. Like I said, same after Power Off, reset and so on ... The hungarian manufacturer can't help us fast (enough), the german Jazz distributor doesn't have an idea yet! Regards Björn
  22. Hello everybody, I have an analog force gauge (4-20mA, -5.000[N] ranged 5.000[N]) . I'm using an OPLC JZ-10-11-UN20. (has 3 AI's and a TC input) I read a few posts in this forum as well as the U90 help example regarding linerarization, and for some reason (probably there's something I'm missing ) it just doesn't work. the force gauge has a LED panel, which showed 0.291 [N], while the U90 program I wrote is attached. I notice changes in the result in the LED panel while applying force, but the U90 showed no change. can anyone point out what I'm doing wrong? secondly, the results I get from the TC (K type, range -200 to around 1000 deg. celsius) are around 220. I understood that since I use this specific model of JAZZ, this would not require special linerarization 22 would make sense, not 220. any Ideas ? does this require some kind of calibration? Thanks , Tzachi
  23. Hi everyone, I'm having problems communicating with Jazz units via USB. I've installed the STMicroelectronics driver, the virtual COM port is shown in the device drivers. And I can actually communicate with the unit initially, but at some point the software can not detect the Jazz anymore. I've rebooted the Jazz, rebooted my PC, re-installed the driver, and just can't link to the Jazz via USB anymore. I actually tried with a different Jazz unit with the same results. The serial communication via the JZ-PRG works fine (not at the same time I use the USB off course). The versions I have are: U90 6.6.0 (DB 109) JZ20-R16 (latest firmware) Windows 7, 64 I'll appreciate your suggestions. Thank You!
  24. Hello, I have a project where I have to send sms messages from a jazz plc (JZ10-11-T40) using a MC55i Terminal modem, however the modem does not respond to plc and i get the error message 2 in SI70. The same setup seems to work fine with the MC35i model, but when I try to connect the other model, it just doesn't work. I can communicate with it using PC and it responds to at commands, but not to jazz initialization commands. When connecting to modem through PC I'm using the same communication setup (9600, 8N1) as the jazz. Is there something extra that I should be aware of or is there a problem with this type of modem?
  25. Hi there, I would like to know if there is a special function similar to the "Copy vector of inputs to a register" for use with outputs. I would like to be able to copy the current state of outputs to a MI register. An alternative would be to use a bunch of contacts and coils to link the outputs to MBs then use the "convert MB to MI" special function. However this does not seem like the tidiest solution. What I am aiming to achieve is having a screen to display the current state of all inputs and outputs. The user will be able to navigate up and down the list of outputs and see their current state. The aim is to achieve this using a single display in the UI. I have already achieved what I want for the inputs. Using the "Copy vector of inputs to a register" function, I can copy the selected Input value to an MI and display that on the screen. It appears that there is only a "Copy MI to output vector" for outputs which is the opposite of what I would like. I would really appreciate any suggestions.