Jump to content

Search the Community

Showing results for tags 'modem'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Our Community
    • Come on in!
  • News and Announcements
    • New! UniLogic V1.24 introduces VFDS from Unitronics!!
    • VisiLogic:9.8.64 - Link to mobile app, Ladder: 2x the Space!
    • New!!! ***** U90 Ladder*****
  • UniStream HMI + PLC Programmable Controllers & UniLogic Software
    • UniStream: Hardware
    • UniLogic Software
    • UniLogic UDFBs
    • Industry 4.0, IioT, MQTT--Looking forward
  • Vision, Samba, Jazz and M90 PLC + HMIs & Software
    • Vision & Samba PLC + HMI Controllers & VisiLogic Software
    • Jazz, M91 PLCs and U90Ladder
  • Software Utilities
    • SD Card Suite
    • Remote Operator
    • Remote Access
    • DataXport and DataXls
    • UniDownloader
    • UniOPC
    • UniDDE
  • Utilities for .net and Visual Studio
    • Unitronics PCOM Protocol
    • COM Object ActiveX .dll
    • .NET driver
  • Project Design
    • ...I have a project...what hardware do I need?
  • User Application Stories
    • Just finished a great project?
  • Tips and Tricks
    • Best Programming Practices
    • Tips and Tricks
  • Job Board
    • Projects seeking Programmers
    • Programmers seeking Projects
  • General Discussion
    • We're Listening...
    • The Lounge
  • News and Announcements Copy

Blogs

  • Unitronics' Blog: PLCs, HMIs and more
  • Saragani's Blog
  • Simon's Blog
  • Ash Neilson's Blog
  • Joe Tauser's Blog
  • Unitronics en Español
  • Powered by AMPS
  • Alldrives UK's Blog
  • Unitronics, Howman Style
  • PLCNewbie's Blog
  • Telestar Automation Blog
  • Webinars Collection
  • Tim's Corner
  • Blog
  • TELESTAR (Italian)
  • i4 Automation
  • i4 Automation (UK)
  • Unistream UDFB's

Categories

  • From Headquarters: Sample Applications
    • From Headquarters: VisiLogic
    • From Unitronics: U90 Ladder applications
  • User-submitted Applications
    • From Users: VisiLogic applications
    • From Users: U90 Applications

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Interests

Found 12 results

  1. Hi, what is the maximum file size that I can send with this modem? The type is in the first image. I find the second image in the manual of modem but I don't understand what type is my modem. And I read the signal quality of modem is ever or 0 or 100, it's possible? Even when it's 0 modem send the mail. The signal quality varies 0 to 100? I set 3 seconds for refresh the signal quality. I don't understand how the signal quality operate. Thanks
  2. 1) When editing IO Inputs or Outputs Alias Names directly (from the table view, without going into window for editing single tag) - cold not put a space symbol between words while writing (later when the whole "Input5AbracadabraOpenSesame" is written, you can, of course go back and put spaces in between words finally getting to the "Input 5 Abracadabra Open Sesame"). Problem is not observed while editing in single tag editor window. This is new mis-behavior, which was not observed some versions earlier. 2) In Data Table view - String literals are center-aligned without any obvious reason, which detracts from readability of large tables. For Number literals it makes sense to have them centered within cells, which more likely adds readability rather than destroys it, but it's a different story for the Strings. 2.1) In the same Data Table view - it is unable to directly edit anything without explicitly going into editor window for each cell with double click... That's so tiresome and time consuming for large tables. Exception is direct Paste, which however helps little, if each cell is slightly different. 3) Alarms - ID's could not be freely changed... I see no obvious reason for not allowing to do that because there are gaps still allowed (by deleting some alarms in the middle) and no automatic reordering of ID's is then happening. Of course it does not change much, but adds to the overall order and clarity of the project. Thus why not allow to change them freely, of course, with checking for duplicates. 3.1) Alarms could not be moved around (between groups for example). Took me few weeks to reorder entire system of 100+ Alarms... 4) Ladder function could not be duplicated, like almost anything other could. 5) The XY Plot is wrong type of thing, or at least I need a different flavor (see attached pictures): a) XY_Beijer is the reference - a single clearly visible point of arbitrary size is drawn for each feed in data sampler; the lines referencing these point(s) to the X and Y axes are drawn (switchable on/off); the background where any arbitrary function could be drawn or at least a clear background where any arbitrary picture could be put into (switched during runtime, not statically linked); b) there is always a cause - see the Weather_compensation; c) and a workaround - see the Comfo_Uni which is far from ideal, but at least works, somehow... Why all of this - I was asked to implement Comfomatic (Weather compensation for central heating) functionality as addition to primary functionality. Typically it is done in special hardware like Danfoss ECL series controllers, however the underlying mathematics is rather simple, so why not.... It worked out - making a usable user interface is a major pain on the Unistream platform.... d) of course in ideal world, I'd be asking the Unitronics team to implement the entire functionality in specialized function block, both for GUI as well as for Ladder, however I understand there are so many uses for these PLCs that implementing separate function block for each of them would lead to the same clutter which was seen in VisiLogic series software and which the Unitronics guys were presumably trying to avoid in Unistream. e) and there is always a workaround of the workaround - or better, I call it suggestion 2: The the simple Canvas control could be added to the GUI section - thus allowing users to draw whatever they need to solve such challenging tasks... (or if the screen is already a canvas itself, then at least allow to draw some primitives - dots, lines & rectangles from the Ladder (yes I know there is a Line element in GUI, but it is static, you can not even put a variable as its X1,Y1 and X2, Y2 points... thus it's unusable). 6) Each MODBUS target has the Modbus Remote Slave structure attached. This structure has very useful variable 'Fail' within it. It could be ideally suitable for checking for communication problems, and throwing Alarm to the user if any. But what's next - user cannot clear the alarm, because there is now way to drop it to the zero (I mean, there is no way to write 0 to this structure). Yes, of course there is again a workaround - copy the contents to another variable and then compare to it, not the 0, But why always a workaround? Why not do the things right the firsthand. 7) I'm still begging for ability to reorder members of the struct, like it's done in SMS Message composition with the List Of Text Variable - simple control to move members up and down. It has no meaning while the project is little and simple, but when it becomes large enough, when various functionality is added to different parts all the time, when structs determine what is written to different tables back and forth, then keeping various recent additions together with their primary counterparts rather than at the end of the struct, could be soooo meaningful. At present its a tremendous and very time consuming job to reorder the structs, by renaming and replacing every single appearance everywhere, when it could so easy be made to happen automatically. Not to mention, that is so easy in plain C, just cut one and paste above each other... Many thanks for the product already that great (light years away from said Vision or Samba), but of course, any improvement would be warmly welcome. P.S. Please double-check the communication with Cinterion BGS2T modem - it tends to drop from time to time (worse with USB-COM, better with UAC-01RS2, but still not ideal) and then it's unrepairable till the next complete reboot of the PLC... (re-initialisation has no effect).
  3. Hi, I try to make a call from the PLC using GPRS and modem Cinterion EHS6T. I successfully prepare the PLC-side modem but when I Start the Call from the PLC it constantly gives me Modem Timeout.
  4. Hi there, I try to initialize Enfora modem PC-side. I followed all of the steps from the tutorials on the Internet. I tried different Baudrates, tried Hyperterminal... When I use Baudrate of 9600, and the AT commands defined in the Modem Services, all of the commands are successfully completed and when it comes to the end it always says: Modem could not be initialized. Do you have any advice what can be the problem?
  5. Hello, I'm using Jazz JZ20-R31 controller together with MJ20-RS add-on module for RS485 communication. Is there a way to use RS485 communication and simultaneously use a modem on RS232? To rephrase the question: I would like to achieve some sort of remote access to data while still communicating via RS485, are there any suitable options (modem, wifi...) ? Thank you, Best regards, Pawks
  6. Hi Everybody I am looking for Visilogic that would support OS version 3 - i guess it should be version 3.00? (the oldest version on unitronics archive is 3.6.2). I am looking for it because upgrade from OS V3.0 to V3.73 broke the program and the modem doesn't want to initialize Please Help
  7. I have a ETM 9440-1 GSM modem connected to a V1040, with 6 recipients in phone book for each SMS to send -the modem initializes OK connects in the V1040 PLC program. When a "SMS send" block is run, the modem sends the message to the first recipient in the address book OK , but then "Status Mesages" for modem return "8 - Unknown modem reply" and fails to send to remaining recipients in phone book? The modem is a Cinterion PH8-P engine, I have used Cinterion MC55i in "Init block" on startup with custom init AT commands AT&F ATE0 AT+CPIN=^XXXX^ WAIT 3 AT&C1&D1&S0Q0S0=1V1 ATX4 WAIT 3 AT+CNMI=0,0,0,0,1 AT^SCFG="Radio/Band",211,1 AT+CPMS=SM,SM,SM AT+IPR=9600 AT&W0 ATI Does the "SMS Send" block have different commands to the modem depending on what modem is selected in "Init block"?? Any help or ideas please. Matt
  8. When I connect TC35i modem to PC via USB-to-RS232 converter everything works greate. Doing "Prepare PLC-side modem" in Modem Services in VisiLogic OPLC IDE result in connection and success. Making a test dial from Modem Services also results in success. But when I connect my PLC (it is V560) with the modem using a 4-wire RJ11 programming cable (ended with MJ10-22-CS25 and simple Male-to-Male adapter) then the Modem Init fails and SB 83 bit become 1 (SB 83 is Modem Init Fail for COM 2). I suppose that something wrong is with the cable. How am I supposed to connect V560 to TC35i? Thanks for help...
  9. Sterling

    USB Modem

    Hey Folks, I discussed this with support yesterday, but I am still having trouble. I have a Sixnet Land Line modem connected to a V350. The V350 has a RS232 expansion port. On the other end I have a US Robotics USB modem connected to a PC running Visilogic and Remote Access. The PC dials and the modems connect. However, I can't go online. I am concerned about the flow control on the USB modem. Do you have anyone with experience with USB modems? Take Care Richard
  10. Hello, Is there a way to read/write (send) data between 2 plc's via gprs modem, using pcom? I'm using V130 and Siemens TC65 at both ends Thanks in advance!
  11. Hello, I am trying to set up a V130 to send out text messages. I am using the Enfora modem and have set everything up correctly I believe. I am using COM1 and have changed the internal jumpers to RS232. I have the COM INIT 1 block running on power up with a baud rate of 9600. I have used the Modem Services to 'Prepare PLC-side modem' with a baud rate of 9600 as well. When I plug the modem into the v130 and cycle power the connection fails (ie SB81=1). Can anyone give me insight as to what I am doing wrong? Thank you, BenB
  12. Hello, I have recently posted asking about how to get the Enfora modem to connect to the v130. I was able to accomplish this by placing a number in the 'Number to dial' box in the modem settings screen. I just put in my cell phone number to test and the modem connected after that with a signal strength of 14. I do not know what the Number to dial should be set as though. I also am trying to send a text message and have everything set up to do so. Whenever I press the #1 button to activate the request to send the Modem Busy bit changes to 1 for a few seconds and then switches back to 0. None of the other status bits change when I do this however. I believe the request to send does change but is activating the SMS Send FB and is then clearing itself before I can see the change. Any help with this is greatly appreciated! BenB
×