Jump to content
Sign in to follow this  
Geert vd Wal

V570 setup problems

Recommended Posts

Hi all,

I am new in the working with these types of PLC's.

I have a v570 and started to make an application. To find out how my application is working I tried to download it to the v570 PLC.

The v570 is connected via a network cable to my PC.

I booted the v570 with keeping a vinger on the screen. That results in a information screen. But the only thing I got there is the IP address and some serial communication settings.

So I configured my network according to this information.

I was able to ping to the v570.

However downloading my application didn't work. It needs somehow a PLC Name. (And I do not know what to fill in there.)

And I found in other disscussions that it should be possible via the information screen to update the OS and to callibrate the screen etc....

But in my situation it just shows the IP and COM information and nothing else. And it does not react on screen touches.

How can I get my software in this PLC????

And how can I get the current configured PLC Name???

Share this post


Link to post
Share on other sites

Hi Geert.

I'm not quite sure i understand the complete problem, but you need to check out the Communication & OS under the Connection tab in VisiLogic. If i understand you correct, it should be set to TCP/IP call. When you are in this tab (altered the connection type), try to Get OPLC information. If the PLC responds, i think you are ready to download.

Regarding the PLC name, this has to be set in the ladder by Set PLC name under Com tab at power up.

best regards gorm

Share this post


Link to post
Share on other sites

The way I tested the communication is pressing the Get OPLC information button.

And that responced with the problem.

I finaly did remove the battery from the v570 and get to the state that there is no application loaded.

The IP address is changed but I still am not able to get connected to the v570.

I expected the PLC Name to be defaulted to the serial number of the PLC.

I am able to ping the PLC but downloading the ladder stuff and HMI pages is not possible.

See also my other more detailed topic

Share this post


Link to post
Share on other sites

I assume you ping the dewice from cmd promt, hence i think the problem is how the project init is configured.

Is the TCP/IP Project Setting from the Project tab corresponding to the IP setting altered from "tapping" the OPLC?

If this is correct, my advice is to reconfigure com setting to serial (use the MJ10-22-CS25 cabel), and put your own PLC name in the ladder under power up. Then reconfig back to TCP setting under Communication % OS and start downloading :rolleyes:

let me know gorm

Share this post


Link to post
Share on other sites

Dumb question- don't you need to initialize the Ethernet port and socket via the ladder?

In other words, if you don't have it set up in the ladder, I didn't think it would connect (though it might still ping based on changes made via the info screen at the PLC).

I'd use the serial cable to download your app to the V570.

Share this post


Link to post
Share on other sites

Starting up V570 ethernet connection from an "new out of the box" condition takes several steps:

Go into the "Info Mode", enter the password (1111), go to "Version", then "Software", and write down the PLC Name that's at the bottom of the screen.

Then hit "Escape" twice, select "Ethernet", then "IP Parameters", and enter your desired IP address and Netmask, then press "Apply".

Hit "Escape", select "Socket Parameters", and set Socket 0's Port to 20256 and the TCP_UDP to "TCP Slave", then press "Apply".

Now go to Visilogic and open your project. Go to "Connection", then "Communication & OS", set "Connection Type" to "TCP/IP Call", check the button for "Favorites", and click the folder icon on that line to open a list of PLC Names, IP Addresses, and ports. Put in the PLC name you wrote down, at the IP address you chose, and port 20256.

After that information is entered, press the "Get OPLC Information" button - you should see the information about your PLC show up in those boxes.

In order to get around having to do this for each new PLC, I have taken to naming all PLCs for a given customer by the same name, since we haven't yet had multiple V570 PLCs on an ethernet network in the plant - we just use it for programming, monitoring, debugging, and Modbus connection to Building Management systems. I put the PLC name, the SD Card password, and the TCP/IP initialization information in the first rung of the program - you can download an example framework program from the link at the bottom of this blog entry.

I then can use the VisiLogic function "Project/Create Project Files" to create a clone file, with project and OS - selecting the latest OS available - and save that file with a name like "ETHERNET" (it has to be 8 characters). I use the SD Card Tools to format an SD Card to Unitronics layout, then put the ETHERNET.c57 file which I created in the /system directory of the SD card. I can then insert that SD card into the V570 PLC, go into INFO mode, select "SD", then "Clone", and "Upload to PLC". That loads the program in, which sets the ethernet IP address and port and sets up the PLC name to the proper one for that customer. Having the SD card with a minimal framework application lets me quickly initialize a new PLC and get it immediately ready to program and monitor over Ethernet.

Share this post


Link to post
Share on other sites

Not at all. Perhaps our friend Mr. T point is correct.

I'm only using Eth port in conjunction with Modbus IP.

For downloading i always use EIA 232 port.

Regardless you have to use the EIA port for the first time.

br gorm

Share this post


Link to post
Share on other sites

Starting up V570 ethernet connection from an "new out of the box" condition takes several steps:

Go into the "Info Mode", enter the password (1111), go to "Version", then "Software", and write down the PLC Name that's at the bottom of the screen.

My question is how do I come into the Info Mode.

I have a kind of info screen but that is only a static screen not reacting on any touch. As described in my first post.

Share this post


Link to post
Share on other sites

Geert,

Chances are you have a "DOS" Screen in front of you at the moment.

Press and Hold the Touch Screen for about 4 - 5 seconds.

You will then be presented with Two Buttons, tap the "Info" Button.

Enter the Password "1111" from there and follow Phil's Instructions :rolleyes:

Share this post


Link to post
Share on other sites

I suspect what you've been doing is holding your finger on the screen while applying power to the unit - that is the "hidden" method of stopping the boot process to allow reload after, for example, an incomplete operating system upgrade. To get into info mode, power up the unit, then once the unit is sitting at a display screen (such as the "out of the box" Unitronics animation) touch the screen for four seconds, being careful not to move your finger around. Then you'll see the two boxes allowing you to select between "Enter Info Mode" and "Calibrate Touchscreen".

Share this post


Link to post
Share on other sites

I was finally able able with help of you all (Many thanks) to enter the Info mode.

There I found the PLC name and the possibility to configure the network IPC/IP settings.

I have now my application uploaded to the PLC and can continue.

Thanks for all your support.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...