Jump to content

Recommended Posts

Hi,

I am using 4 nos of DI16 AI3 TO16. I am using the 5th I/P on each of these as High Speed Counters without Reset. These I/Ps have bben used primarily to capture some very fast signals. I will be performing some process as soon as the value in the designated MIs counts 1. After the logic has been solved, I need to RESET the respective counter. I have tried my best, but am not able to do so. Immediately RESET HSC does not work. --{R}-- MI does not work. Is there a solution to this?

Pl reply at the earliest

Ron

Share this post


Link to post
Share on other sites

Are you using an A1, A2, or RC1?

Input 4 is the HSC input, input 5 is the Reset for the HSC.

When you configured the input in hardware, did you select just "High Speed Counter" or "High Speed Counter with Reset"?

Share this post


Link to post
Share on other sites

Hi Damian,

I am using an EX DI16AI3TO16 + 3 X IO DI16AI3TO16. As stated by you I/P 4 is the HSC or as I may call it the 5th I/P. I have configured it for "High Speed Counter" Only.

Hope to receive a solution soon. Have to implement it at site tommorow.

Thanks

Ron

Share this post


Link to post
Share on other sites

So as I see it the problem is that you can't reset the linked MI value via ladder.

Have you also tried using a Store Direct to store zero? This should be the same as the ---[R]--- numeric, but you never know unless you try.

I don't think the Immediate functions work on the Expansion I/O, only the Snap modules. I have had some troubles trying to clear counter MIs in the past, but the exact circumstances are a bit vague in my memory.

The catch-all solution is to use the following sequence.

Copy counter MI to a new MI

compare new MI to a buffer copy (from the last scan)

if they are different set a bit to flag that a count has been detected.

Copy the new MI into the buffer copy (ready for the compare on the next scan)

The linked MI on the input will keep counting forever, but this logic will detect as soon as it changes by 1 or more counts between scans.

Another option is to configure the counter with Reset and use digital outputs from the I/O module to pulse the hardware reset line.

I hope this helps,

Share this post


Link to post
Share on other sites

Thanks Simon,

I had also thought of using the same dual MI comparison method for detecting two of the fast occurring signals. However my problem now remains that I am also using an Encoder of 1024 PPR of Kubler make. I have to use these pulses to emulate a cam. The reset ( Z Pulse ) of the encoder works at slow speeds upto 20 RPM, but above this speed, tehre is no resetting occurring. I may now have to instal a snap in module just to acheive this.

Ron

Share this post


Link to post
Share on other sites

Ahhhh, the "Z" pulse.

The ony way to capture this at anything resembling full accuracy is to use a second high-speed counter and monitor it with an interrupt. You are still limited by the interrupt speed, so it is not possible to reset the main count exactly when the Z-pulse occurs.

Is it possible to use an absolute encoder with parallel binary output? This makes the Z-pulse irrelevant, as you are always reading the position directly as a number. For a 1024 pulse encoder, you just needs 10 digital inputs, all from the same I/O module.

Share this post


Link to post
Share on other sites

Well, i consider myself experienced user on Vision PLCs. Now I am facing a problem that is blowing my mind! i use maximum loaded V570 configuration (Snap-in, 4 x DI16, 2 x TO16 and 2 x AO6X with EX-A2X adapter). I already use incremental encoder on my Snap-in module (A, B and Z pulse) emulating absolute encoder. But i need two more counts in order to determine some sync points on the other moving parts on my cartoning machine. So I connected just phase A of an incremental encoder to expansion DI16 module and in HW configuration make it work like a HSC. It counts up all right. But it doesn't let me reset MI1 connected to it no matter what I do. I tried to use Reset numeric, storing #0 to MI1, even in on-line mode it won't send 0 to MI1! Then I tried to trigger physically (with 24V, PNP configuration) Hardware input #46 designated as the Reset input for a HSC that uses input #47 as the HSC (and counts!) - still nothing.

I absolutely need to reset MI1 before I make a move that will produce counts on every machine cycle!

Any help, please?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...