Jump to content
Sign in to follow this  
ragnarg

Ethernet comms. via switch

Recommended Posts

Hi all,

I have several similar projects of which I am starting the first one. A single V280 on a small ethernet network with a single switch (or a router) and a single PC. All communications work fine when using a direct link (ethernet crossover cable) between PLC and PC, i.e. using Visilogic, DataXport and UniDDE. When I try to go through the switch or the router there is no way I can even ping the PLC fro the PC. Why on earth is it that I can't even ping the V280 via a dumb switch?

Hope someone can help!!!

Best regards,

ragnarg

Share this post


Link to post
Share on other sites

I connect to a V570 via a 24-port switch all the time, for what that's worth. Could there be a cabling issue, or a bad port on the switch? Is it a 10 base T hub and your computer has its port locked to 100? If it's an unmanaged switch, it should just forward any traffic it sees regardless of the IP address ranges involved, so I'd really suspect a hardware/cabling issue.

Share this post


Link to post
Share on other sites

Hi Phil and thanks for your reply.

I have checked (replaced) the cables, and altered the switch ports (or router ports, which I have at the same place) - no change there. I also tried the same setup in another project (V130 <--> Laptop) and it behaves the same i.e. comms work using a crossover cable but not via the switch.

The switch I am using is a D-Link....

http://reviews.cnet.com/switches/d-link-dgs-1005d/1707-6432_7-30540496.html

The Ethernet card in the Vision controllers are set to slave mode. Do I need to send some sort of message from the controller to the network announcing it's existance and it's IP number? I wonder if the switches/routers need some sort of comms. innitiation from the controller???

I am not much of an networking expert but I believe this ought to be pretty much straight forward.... it how confuses my simple mind :blink:

Any suggestions....

Share this post


Link to post
Share on other sites

Suggestions -

1. turn of auto negotiation on the switch and force to 100MB full duplex.

2. make sure you NOT using a crossover cable - it should work either way, but remove it as a potential error source

I would force the Unitronics to the same settings if I could, but I couldn't figure out how to do it.

Conversely, if you find the ports are manually set already, try setting them to auto negotiation.

Share this post


Link to post
Share on other sites

Hi - thanks for your suggestions.

I had a word from site sying that the comms. worked all of a sudden when the normal patch cable was replaced by a screened CAT5 cable. The normal patch cable is in perfect working order. Is it normal that the comms. should halt if a screened cable is not used? Bearing in mind that a direct connection (PLC - PC) via un-screened crossover cable was successful.

Best regards,

Ragnar

Share this post


Link to post
Share on other sites

Hi - thanks for your suggestions.

I had a word from site sying that the comms. worked all of a sudden when the normal patch cable was replaced by a screened CAT5 cable. The normal patch cable is in perfect working order. Is it normal that the comms. should halt if a screened cable is not used? Bearing in mind that a direct connection (PLC - PC) via un-screened crossover cable was successful.

Best regards,

Ragnar

Sounds like you had a ground loop that the screened cable may be squelching. How close is the switch to both devices?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...