Jump to content
Sign in to follow this  
Vidmas30

V570 fatal error several times a week

Recommended Posts

Good day,

We have deaerator control system where used V570 with ETHERNET card (PLC always conected with Unitronics remote access software). As we started application, all was well, but after couple of month, now we have fatal error screen several times a week. The information on screen told me local supervisor:

V290/B570(T20B)

O.S. (STOP MODE-FATAL ERROR)

003.004.25 November 27, 2011 9:56

----------------------------------------------

ENUM: 0x0001100 00000000

IP: 0x0007043A 0007766A

LDR: 0x0000017A

DESC: ILLEGAL WORD OPERATED ACCESS

STATUS: IDLE

© COPYRIGHT BY UNITRONICS

Maybe someone coul tell what may be the cause of that fatal error?

We assigned IP address to Ethernet card that was free at the moment we were installing PLC. Could this fatal error be if they for example bought new computer and used same IP address as PLC's?

Thank you very much and looking forward to solve this issue asap..

Share this post


Link to post
Share on other sites

Fatal Error is usually caused by an error in the program, divide by zero, stuck in a loop, trying to call a variable that doesn't exist, etc.

If you send your program to support@unitronics.com with a description of the problem we should be able to help you find a solution.

Share this post


Link to post
Share on other sites

Thank for quick anwer,

As I mentioned: program went good couple of months. Then something happened with ethernet connection (ethernet card was stopped, SDW39 showed error status in info mode). After RESET, all was good. But then begun fata errors. I still think that it's something with communications..

Is there possibility to tell the exact reason by these error messages I wrote?

Share this post


Link to post
Share on other sites

The reason for Fatal error can be also strong picks of electromagnetic noise. Maybe something changed in the controller environment? New big machine? Or contactor in the cabinet started to perfomr worst, emmiting more noise?

You can try function "Check subroutine by error code" (VisiLogic > Edit menu). This function will point you to the subroutine, where the application stopped with this fatal error. This can give you some direction.

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...