Jump to content
Sign in to follow this  
bc_fred

OPCEnum as Service

Recommended Posts

HI:

I am attempting to connect Wonderware InTouch to a Vision 350 PLC via UniOPC. I have installed OPCLink 8.0 for the Wonderware side. I have installed and run UniOPC for the Unitronics' side. I am communicating normally with the PLC via TCP/IP for VisiLogic. My computer is running XP Pro, SP2.

I have worked through the UniOPC installation and configuration manual several times. When I get to configuration of OPCEnum as part of DCOM, when I get to the Identity tab in OPCEnum properties, the documentation indicates to select "The System Account (services only)" at the bottom of the Identity tab. However, in my case, this option is unavailable, grayed out.

As a clue, when I look at the General tab for the OPCEnum properties, OPCEnum is listed as a Local Server for Application Type, whereas the UniOpc documentation shows it to be a Local Service.

Does anyone know any way to make the computer think that OPCEnum is a Local Service rather than a Local Server??

Thanks in advance!

Fred

Share this post


Link to post
Share on other sites

Hi,

Are you running both UniOPC server and the Wondeware on the same PC?

If yes then you do not need to use OPCEnum.

Please note that there is no option to tun UniOPC server as service.

Share this post


Link to post
Share on other sites

Hi,

Are you running both UniOPC server and the Wondeware on the same PC?

If yes then you do not need to use OPCEnum.

Please note that there is no option to tun UniOPC server as service.

Thanks for your comments.

I independently discovered that you can start OPCenum as a service by entering "opcenum /service" at the Run command. This allows you to complete the configuration of OPCenum as described in the UniOPC manual dated 16/4/08.

There is no mention in that document that you don't need to use OPCenum if you're running both Wonderware and UniOPC on a single computer. In fact, this manual would lead you to believe that both ARE running on a single computer.

Regards

Fred

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...