Jump to content
PCSControls

EMail stops sending during the night & weekends ???

Recommended Posts

I've got a V570 with an application that sends out an email at a selected interval if an alarm occurs. I set the alarm to ALWAYS occur and the email to send every 1/2 hour and all is apparently fine and I see the emails as expected. On a regular basis the sending of the email will stop from approx. 8 p.m. until about 7- a.m. the following day, the stoppage also occurs thru the entire weekend. I have changed ISP's and have installed different routers and switches during the time I have seen this problem. I am looking for any ideas that could help me track this problem down.

Share this post


Link to post
Share on other sites

Hey PCS Controls,

Not knowing your network, from an outside perspective this seems like your firewall is set up to block ports on weeknights and weekends. Does your company block internet usage on nights and weekends? I had the exact thing happen at my facility. We had to allow and exception for the PLC IP addresses. I know you said you changed routers and switches, but it just seems a firewall policy would do exactley that.

Joe W

Share this post


Link to post
Share on other sites

I thought the same thing regarding a restriction from the firewall or router. However I investigated that with the old system and found nothing and there isn't supposed to be anything on the new one either but I will check again,Thanks

Share this post


Link to post
Share on other sites

I had my ISP monitor the traffic leaving our router and they see the messages going out to my mail server even when the emails fail. I then went to my email server provider and they claim that there are NO time restrictions on the email processing. The message being sent is identical each time so I'm having a hard time blaming it on the email contents. This morning I had a bit of time to look at this during the fail time period and saw the error "7 – The server cannot receive data (DATA mode error)" when the message failed. I let the system run and it magically started working again around 7 a.m. this morning and probably will until about 8 p.m. tonight, One additional item is the times are approximate but are around 7 a.m. to 8 p.m. and weekends. Any one have any ideas for me?

Share this post


Link to post
Share on other sites

Create Data Table and trace sending email results. do retry for one email for statistics. Save failure code.

You can open DOS window at your PC/Laptop and connect to e-mail server by Telnet "telnet xxx.xxx.xxx.xxx 25"

(You can find at Internet how to do this).

Check server replay and send short e-mail.

Look for replay.

This will tell you if PC to E-mail Server communication works or not.

Do the same test with other email provider.

For me it seems E-mail provider problem.

You can create Data Table, where you fix e-mail send result and error codes.

Retry sending email to other e-mail server at the time when error happens.

Ask in forums if anybody have the same problem to send e-mails with the same e-mail server.

B.R.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...