Jump to content

Recommended Posts

Hello.

I am building a program to drive an animated water fountain. I am having a problem with the builtin alarmserver that is available on my Vision 570.

The way i have structured my program is this:

I am using subroutines and datablocks to get a function block like functionality. However, this means my cycle scan time has reached 70ms.

Next i am trying to configure the builtin alarm server. Just for testing, i added two alarms to group 0. Both trigger on value "1".

Just as an experiment, on the positive edge of the "one or more alarms is pending" bit that is output by the alarm group function, i am displaying all alarm groups with the show groups FB.

The problem that i am noticing is somehow linked to the scan time.

Anyway, what happens is that when i trigger one of the alarm bits, the various outputs of the alarm group function (for example number of pending alarms) do not update. They remain at the previous values (0 since at plc start i have no errors).

However, if i disable some nets from the main program and bring my cycle scan time down to under 20 msec, the outputs of the alarm group function work when i start triggering alarms.

To me, this suggests that the alarm server does not run if the scan time exceeds a certain value, since the code for displaying the alarms is the same in both situations and only works in one.

I have tried to find more documentation on this issue but was not able to.

Another question would be, how do i change the watchdog timer value ? Is it even possible to change it ?

Share this post


Link to post
Share on other sites

Hello,

Can you try to use a direct coil to drive this operation. If you use a set coil driven from the positive transition, then reset the coil to drive it low again. Also it could be a condition with the program sequencing. You may be jumping to the page before it is updated in the scan. Can you ensure the subroutine jump for the function is in the main routine. On an added not you will not be able to manipulate the watchdog. If this is being triggered it may be a program sequence condition where the controller cannot complete a full cycle before triggering. This can also be caused by loops in the application.

I hope this helps your condition

Share this post


Link to post
Share on other sites

Hello Michael_P. Thank you for your answer.

In the meantime i have emailed someone in Israel technical support, and they have discovered the problem. The alarm server had indeed stopped running because i had left an Online point in the code, and apparently we are meant to remove them when we intend to run the program, as it may cause unintended consequences.

As soon as i disabled the net with the online point the alarm server started working perfectly ! That is why, when i had disabled a great deal of the program in order to decrease the scan time, i had unknowingly disabled the online point and everything worked !

Oh and too bad we cannot change the values of the Watchdog timer :(.

Share this post


Link to post
Share on other sites

20 mS?  Wow!  I'm running an entire automated welding line and not hitting a scan time that large.  How big is this fountain?  Can you post a picture?  I'd love to see it!

Share this post


Link to post
Share on other sites

I am having the same problems with the Alarm server? It is quite a large program no problems until I enabled the alarms.

 

When the alarm trigger bit is active the scan time goes from 3ms to 104 ms and the screen flickers and is unresponsive?

 The Alarm trigger is a SET coil, only while it is active the scan time is 100ms or more

 

Prior to enabling the alarms the program was working well.

 

Do you have any suggestions why this is so??

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...