Jump to content
Sign in to follow this  

Recommended Posts

Hello to everyone,

 

just a short but in my opinion important question:

 

Is there a compatability table out there, which VisiLogic version is working with which OS on which PLC??

 

It's just a thing (to me) as often Unitronics recommends on having the latest OS installed and having the latest VisiLogic installed....

 

I mean, for sure, it's (mostly) the best to have everything up to date, but seriously, having about 60 PLCs out with remote access to only 30% of them, and just going to "let's update them today" just to find that something's not working the way it did before is not a favorite usage of work time to me.

 

Just an example: I had a PLC working fine when program was on (written in 9.3.1). Then it seems, someone uploaded a newer version of that exact same program (two MBs added) with 9.4.0 .... suddenly i couldn't use the display keyboard to enter values (despite the fact that the PLC went to STOP-Mode without showing errors) - no let me correct that, it showed me the place where I could enter them and i was able to press on the screen so that something would be entered, but I don't know what I entered as the complete keyboard was invisible.

 

I had to reupload the program by using 9.3.1 and additionally had to downgrade the OS from 3.6(03) to 3.4(16).

Now it's working, but nobody knows why.

 

So, would be nice to know (e.g. in a table) which OS is compatible with which VisiLogic on a PLC. Also would be nice to have a download section for older OS, Boot and BinLib versions, to be able to downgrade for testing purposes and/or troubleshooting.

 

Thanks and have a nice day,

FireNeck

  • Upvote 1

Share this post


Link to post
Share on other sites

Firstly, I agree with your comments.

 

The version swapper goes part of the way to answering this, though it mainly reduces the time taken to find the right version, rather than eliminate the need to search.

 

If you put the swapper versions on your PC you can go through them and find the version of OS that belongs with each version of Visilogic.  The firmware files are in and around  the following location (example her for V1040/V1210 OS files):

 

C:\Program Files\Unitronics\Unitronics VisiLogic_C V931\Data\Os Vision\V1040\OS

 

It has been an idle fancy of mine to create a collated list, but I usually end up just going back to my swapper versions and looking it up (i have collected a few over the years).

 

I do what I can to counsel users on keeping backups and keeping good records of what is on site, including version information.  This doesn't cover all the bases, but in many cases we find users who keep absolutely no records at all.

 

 

 

Going back to your specific problem, around the time of version 9.4.0 there was an update made to the on-screen keypad images for the V1040/V1210.  Advice at the time was to download a blank project during the upgrade sequence, to ensure that the PLC received a copy of the new images.  I can't remember the exact sequence.  I think if you also do a "build all" of your project before downloading in 9.4.0 it also helps.

 

I think this was mentioned in the "What's New" section of the Visilogic 9.4.0 helpfile.

 

This post has been full of vague comments, but I hope at least some of it has been helpful.

Share this post


Link to post
Share on other sites

Hello Simon,

 

yes, you're right as far as that there are older versions of OS in the folders of the older VisiLogic versions.

But there is always just one older OS, or let's say "the latest OS for the compatible VisiLogic Version".

 

Just an example: in the folder for VisiLogic 6.01, the OS therefor V570 is 1.02(08). But I need for some old PLCs in use OS 1.02(01).

Another Example: VisiLogic 9.3.1, V1040. OS installed on the PLC is 3.03(00), latest OS in folder is 3.03(16).

 

For troubleshooting it would be nice to have the old OS files so that it's possible to see if the change from like 1.02(08) to 1.02(01) has an affect on the program running or not.

 

Believe it or not, I had a system which was not able to run at 1.02(08), but with 1.02(01).Don't ask me why, but you know "Never touch a running system !"

 

As for the table it would be nice to at least see, which OS is "connected" to which VisiLogic, so that you don't have to search all the folders which OS is combatible to which VisiLogic.

Maybe it's just a luxury problem which only I came across, but you know, there has to be something to complain about so that Unitronics always has something to do.... :D

 

 

But thanks for your answer anyway, I didn't realize at first that there is OS in the VisiLogic Swapper folders.

 

Thanks,

FireNeck

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...