Jump to content
Sign in to follow this  
Rene

Modbus TCP communication error with certain IP address

Recommended Posts

Help wanted!!!
After replacing older V570-57-T40B PLC to new one (V570-57-T20B with latest firmware, project file created earlier with Visilogic version 7.0.3 is converted now to 9.5.0) the Modbus slave communication simply does not work anymore. The V570 Modbus TCP slave connection doesnt work with PLC IP address 193.142.204.85. Is there some new address range limitations for Modbus? Socket status monitoring shows me that socket is connected, but PLC simply doesnt answer to Modbus data requests from SCADA system. Ethernet connection itself is OK (Visilogic can communicate with IP address 193.142.204.85, but Modbus not)
Everything worked well with older PLC and firmware and there is no changes made in PLC project and SCADA software.

 

Share this post


Link to post
Share on other sites

From visilogic menu try Build>Build All, then download project again.

From my experience, Modbus never works well after conversion without rebuilding the project.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...