Jump to content

Recommended Posts

Please help newbie!
 
My objective: to make the remote reading of water meters and electricity to a building using vision 230.
 
I wrote a small program to play with the meter and understand how everything works. But suddenly confronted with problem! The reading data from meter are not displayed. And I can not understand where i made a mistake.
 
Maybe there is a similar project example or someone can check my programm.
 
My meter telegramm:
 
68|29|29|68|08|00|72|64|78|13|04|01|6A|01|02|00|00|00|00|86|10
83|00|00|00|00|00|00|00|86|20|83
00|80|67|D8|08|00|00|02|FF|92|00|1E|00|C8|16
 
Primary m-bus address: 00
 
Thanks a lot!
 

 

meter reading.vlp

Share this post


Link to post
Share on other sites

Hi Kycayca,

There are several problems in the application:

1. The function blocks COM Init and Protocol Config should run once on startup (use SB2 contact) in the Main Routine.

2. There is no correlation between the telegram described above and the definition of Protocol Scan FB.

 

Please send the exact specification for the message for further debugging

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...