Jump to content
micapp

Current output from V200-18-E1B when PLC is in STOP

Recommended Posts

I have a problem with a valve control. The controlsignal is 4-20mA. The control works very good when PLS is running.4-20mA give  decimal values 820-4095 on output. If I switch off the PLS, there is of course no value on output that is recognized as control signal by the valve, and it does not move (error condition on 4-20mA signal say that valve shall be in last position).

 

The problem is when the PLS goes to STOP, the value on the PLS Memory Integer is still 4095 (fully open valve), but the output from V200-18-E18 give an output the the valve control read as GO tO 0% (closed posistion).

 

Any idea what to do to get around this?

Share this post


Link to post
Share on other sites

I have a problem with a valve control. The controlsignal is 4-20mA. The control works very good when PLS is running.4-20mA give  decimal values 820-4095 on output. If I switch off the PLS, there is of course no value on output that is recognized as control signal by the valve, and it does not move (error condition on 4-20mA signal say that valve shall be in last position).

 

The problem is when the PLS goes to STOP, the value on the PLS Memory Integer is still 4095 (fully open valve), but the output from V200-18-E18 give an output the the valve control read as GO tO 0% (closed posistion).

 

Any idea what to do to get around this?

I think that the most important question in you case is - why does the PLC goes to stop mode? This is not normal and might happen from several reasons.

If your PLC is going to stop mode right after the valve operation command, I will assume that your power supply is not powerful enough (this is assuming that the same power supply is powering both the PLC and the valve). If this is not the case, your system could be suffering from EMI, that is affecting the PLC normal function.

 

Please write to support@unitronics.com and explain more thoroughly about your system and when it goes to stop mode.

Share this post


Link to post
Share on other sites

One instance is when downloading new program. Normally is not a problem, and if it is a system definition, I must live with it. But I had a hope that the output should be able to control as long as the MI-value is correct.

Share this post


Link to post
Share on other sites

One instance is when downloading new program. Normally is not a problem, and if it is a system definition, I must live with it. But I had a hope that the output should be able to control as long as the MI-value is correct.

Well, you shouldn't "live with it" no matter what.

Please send the application to support@unitronics.com. I suspect there is some programming issue there.

Share this post


Link to post
Share on other sites

If the PLC can stop and you can't live with the output being stuck at 4095 then you need to put a bifurcated relay in series with the control signal and have the output always on while the PLC is running.  It will go off when the PLC stops and disconnect your loop.

 

Joe T.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...