Jump to content

Recommended Posts

Hi

 I'm trying to print a pretty complete of a project. I would like like to keep a hard copy with the wiring diagrams of the new system.

However eveytime I try to print a report in VisiLogic I am including all subrotine,All HMI Displays, Harware Config and data types that I have used.

Whenever I go to print either to a real printer or if I'm using a pdf distillers. it appears like the print is being generated and before it starts printing I get an error that reads

Runtime error 13 then after I ok the error I get runtime error 440 and visilogic shutsdown.

Any ideas what could be causing this and what I can do to get a printed reoprt.

Thanks

Michael

Share this post


Link to post
Share on other sites

Hi mrdegold,

Which Visilogic version are you using? I tried printing in Visilogic V7.9.24 (the latest version) and it prints just fine. Try to upgrade if possible.

If you are using the latest Visilogic version, please send a screenshot of the Print Menu so I can try to simulate.

Share this post


Link to post
Share on other sites

Eyal

 Thank you for getting back to me.

 I believe I am running the most up to date version of visilogic as you can see in the attached "About.gif" file

The "Printsetup.gif" shows the setup I'm trying to use to print my report.

As I said it appears that visilogic is spooling the information to create the report at which point I get the errors as seen in "Error1.gif" image. When I click ok on the first error I get the error dipected in the "Error2.gif" image at which point visilogic shuts down. When I restart Visilogic I get the message that It was shutdown improperly and would I like it to recover

 I apprecaiate any help you can give me.

Michael

post-8175-0-24220500-1418743328_thumb.gif

post-8175-0-37592300-1418743364_thumb.jpg

post-8175-0-90523300-1418743384_thumb.gif

post-8175-0-66235700-1418743399_thumb.gif

Share this post


Link to post
Share on other sites

Eyal

 Thank you for getting back to me.

 I believe I am running the most up to date version of visilogic as you can see in the attached "About.gif" file

The "Printsetup.gif" shows the setup I'm trying to use to print my report.

As I said it appears that visilogic is spooling the information to create the report at which point I get the errors as seen in "Error1.gif" image. When I click ok on the first error I get the error dipected in the "Error2.gif" image at which point visilogic shuts down. When I restart Visilogic I get the message that It was shutdown improperly and would I like it to recover

 I apprecaiate any help you can give me.

Michael

 

Please re-download Visilogic from Unitronics website and follow these instructions:

 

Backup you projects and delete all the files related to Unitronics installations.

·         Erase the “Unitronics VisiLogic_C”  folder  from- C:\Program Files\Unitronics

·         Erase the “Unitronics”  folder  from- C:\Program Files\Common Files.

·         Perform Windows update and restart the PC

·         Log-on as administrator

·         Save the setup file on your desktop and make sure that the installation file is not blocked (Right click on the file>Properties) If yes, just click on the unblock button

 

 

·         Install VisiLogic.

 

After the installation is done, go to the properties of VisiLogic shortcut and under compatibility ticked verify the privilege Level “Run this program as an administrator”.

Share this post


Link to post
Share on other sites

Thanks Eyal

 I've tried your sugestion. In fact to assure I had followed your directions correctly I have tried several time. I am still unable to print a report with the setup that I discribed earlier.

What I have found is that the problem seems to be while attempting to print the HMI. I was able to print a logic only report. Then while trying to print a report on the HMI I could print 1 or 2 screens then I got the same errors when I went to the third screen.

 As before any help would be appreciated.

Thanks again and Happy Holidays

Michael

Share this post


Link to post
Share on other sites

Thanks Eyal

 I've tried your sugestion. In fact to assure I had followed your directions correctly I have tried several time. I am still unable to print a report with the setup that I discribed earlier.

What I have found is that the problem seems to be while attempting to print the HMI. I was able to print a logic only report. Then while trying to print a report on the HMI I could print 1 or 2 screens then I got the same errors when I went to the third screen.

 As before any help would be appreciated.

Thanks again and Happy Holidays

Michael

Please ensure that your User Account Control settings are switched to Off.

Also, you are welcome to post your application here and I will try to print is on my desk.

Share this post


Link to post
Share on other sites

Eyal

 Thanks again for your support. I truly appreciate it.

I wasn't sure how to attach a file to this post so here is a link to the files dropbox location.

https://www.dropbox.com/s/9btz1a8xj8aqjva/Railcar%20Control_Main_11.vlp?dl=0

 As a reminder I was able to print the ladder report the problem lies in printing the HMI report.

I am curious what the hang up is so I can try to advoid in the future.

 

Thanks again

Michael

Share this post


Link to post
Share on other sites

Eyal

 Thanks again for your support. I truly appreciate it.

I wasn't sure how to attach a file to this post so here is a link to the files dropbox location.

https://www.dropbox.com/s/9btz1a8xj8aqjva/Railcar%20Control_Main_11.vlp?dl=0

 As a reminder I was able to print the ladder report the problem lies in printing the HMI report.

I am curious what the hang up is so I can try to advoid in the future.

 

Thanks again

Michael

 

Dear mrdegold,

I referred your application to our R&D department. They found a bug in Visilogic that caused it to crash and already compiled a fix for this issue.

This will be solved in the next release of Visilogic, which should be out soon.

Thanks again for making Visilogic better.

Share this post


Link to post
Share on other sites

Eyal

 Thank you for getting back to me. It's somewhat of a relief knowing that the problem isn't something I was doing incorrectly.

I would like to wish you and everyone at Unitronics and on the Forum a Happy New Year

Michael

  • Upvote 1

Share this post


Link to post
Share on other sites

Eyal

 Thank you for getting back to me. It's somewhat of a relief knowing that the problem isn't something I was doing incorrectly.

I would like to wish you and everyone at Unitronics and on the Forum a Happy New Year

Michael

 

Dear Michael,

It is our job here at Unitronics. Thank you for helping us make Visilogic better.

Happy new year.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...