Jump to content
Sign in to follow this  
Zipbier

Ethernet Add-on for Jazz 2 | Activitang modbus

Recommended Posts

Hi,

 

I have a JAZZ2 PLC(JZ20-JT40) with OS V2.35(B08) and with ethernet addon(MJ20-ET1). The plc comes with 2.36 OS but, I have to reflash it because its totally crashed somehow. I can't start it.

I am able to connect with the programmer software(V6.6.6 latest).

I want to acces to the plc by modbus communication. I set up the sample program by the instructions on the help topic. The modbus topic is shows that, I must store some values to SI.

I attached the screen of the sample program. I think the SI values displays weird values.

 

What do I wrong?

 

Thank You

post-30596-0-28727700-1433849920_thumb.png

Share this post


Link to post
Share on other sites

When using special functions you will not directly see the values change within each SI. All the special functions use the same SI's so the value will never remain constant.

 

Currently it appears as if you have set up Modbus correctly. How are you attempting to connect to the unit? From the Modbus Client are you receiving any status messages? Also, are you connected to the Jazz controller while trying to connect? Our Ethernet card can only support 1 connection at a time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...