Jump to content
Sign in to follow this  
Gugulanov

Meaning of "pen icon" in ladder and HMI

Recommended Posts

Hi all,

What is the meaning of "pen icon" appearing in ladder and HMI sections in solution explorer?

Because, I  save the project - all pen icons disappears, quit Unilogic, start Unilogic, open the same project, and the again I have these "pen icons".

 

Similar issue is: in the same project I have HMI with data table visualisation. In the properties window I have chosen the right table and tag for "Tag:Selected Row". I save the project, guit Unilogic, start Unilogic, open the same project, and "Tag:Selected Row" is empty.

 

Any ideas for this strange behavior, and aren't the two issues connected?

 

Regards

Share this post


Link to post
Share on other sites

Dear Gugulanov,

 

the "pen icon" that appears means that some modifications were done in the correlate HMI or LADDER function...theoretically after a "save" action it should disappear and if you "load" a project it should not appear because  all modifications were saved or not modifications were done. I have had same "issue", in a existing project, when I upgraded from version 1_15 to 1_16...with new project I don't have anymore.

About the second question I don't know.

 

regards

Share this post


Link to post
Share on other sites

Yes, we aware of the problem with the pen icon appearing after a project was re-opened. This issue will be fixed on the next version.

 

Regarding the Data Table element, it seems that something is wrong with that element. The easy fix is to delete the element and put a new one instead.

Share this post


Link to post
Share on other sites

Thanks for quick answers!

About the data table, I noticed something strange. When I open the saved project with "Tag:Selected Row" field empty (which had been linked with tag before "Save"), while performing "Find" for this tag, in results this tag is part of the Data Table object in the HMI screen, but in fact the field in properties is "Empty" .

This happens with all HMI tables in the project.

I tried to replace the tag with new, as you propose, but without luck - same thing.

 

 

Regards

Share this post


Link to post
Share on other sites

Hi

 

Meanwhile, I think that I managed to remove the problem. Deleting the data table widget and creating it again fix this disappearing of the tag.

BUT,

What is the story:

- I'm writing projects for 2 panels. The projects will have a number of same screens.

- from project for first panel I make "Add to library" of 6-7 HMI screens, all with data tables in them, in order to save time and work.

- in project for second panel I import these screens from library.

- in all these imported screens I had the same bug - missing tag for selected row.

 

Now I'll re-create all tables in second panel's project, in order to fix the things.

 

You can check if there is really bug in import/export function to library in Unilogic software.

 

Regards

Share this post


Link to post
Share on other sites

Thank you, and sorry for your inconvenience,

 

I've been successfully able to reproduce the bug. There is indeed a problem with the Import of the Data Table element.

This bug affects all 3 Selection tags in the Widget (Row, Column and Array member).

 

 

I've opened a bug report for this issue. It will be fixed on the next release.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...