Jump to content

Recommended Posts

Good Evening

I am building a ASCII string from 4 separate ASCII strings

I have that bit down ok....

I am modifying the numerical items using separate fields on the HMI then converting to ASCII before they show in the string

3 of the 4 items change immediately on the  combination ASCII string

the 4th item always doesnt change cleanly on the HMI,it always sort of overwrites the number. I only have numbers between 0-3 so I see all of them on top of each other.

If I view using remote access it looks perfect and when I am in live mode the strings change properly.

I have set different refresh bits, but everything I have done is to no avail

Anyone have any ideas?

post-14124-0-04593300-1460763232_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Dave,

 

My first thought is that it is sequentially changing your numbers on you in each scan in the link to the display.  The "direct" connection of the plc is quick enough to show this on the screen, but that is why it looks ok on remote access and live mode, as the rate of transfer there is much slower and it only picks up what is sent at a particular moment.  Do the numbers change, but slower, during remote or live?  I would be looking hard at your code relating to that area....is it out of whack in first to last net order;  is it being affected by another bit of ladder or call/return that you've missed;  is it being called incorrectly;  is it somehow counting through your numbers as it assembles the string, etc etc?

 

The little men (and women) running around inside the plc are very dumb and easily confused if you don't get their instructions exactly right!  In this case it looks like their arms are getting very tired hanging the 4 digits up and down and up and down and up.........!  And saying that...in the jpg I don't see a 0 in the overwrite, yet you say you are using it. Does it ever show up as part of the muddle, or is it just that the photo missed it?  Maybe that's part of the issue, in that you've got something starting from 1 instead of 0, causing an each scan counting loop because a halt reference is wrong.

 

Cheers,

Aus

Share this post


Link to post
Share on other sites

Aus

It wasn't the little people getting confused it was me!

the field length wasn't quite bit enough to show, all I did was to increase the field size and off she went properly

Believe me I went through all of the coding, even added a refresh HMI set bit (hate that)

anyway thanks for the help

Share this post


Link to post
Share on other sites

The little men (and women) running around inside the plc are very dumb and easily confused if you don't get their instructions exactly right!  In this case it looks like their arms are getting very tired hanging the 4 digits up and down and up and down and up....

 

You kill me, Ausman!  :D

Share this post


Link to post
Share on other sites

That's great Dave, and it is a quirk that is worth knowing.  I've had overlaps myself that do strange things...didn't think of it in this regard, though.

 

And yes...we have to FLEX those smiley muscles now and then ha ha.

 

cheers,

Aus

 

Share this post


Link to post
Share on other sites

Hi All,

 

Attached is the picture where I have an issue in English to French translation,needs some inputs from team.

 

When I translate the English Characters in French the characters such as e (with a tick mark) it allows to save me in font Arial 8 & Arial 12,B only.

If u notice in the attached pic I had Arial Narrow and preview on PLC screen shows as * for special characters.

Is that mean I need that special characters to be displayed only in above said fonts only or can I save the same in other fonts too.

 

Please throw some light on this.

English To French Screen

 
 
Cheers
Vj

Share this post


Link to post
Share on other sites

I think, but not sure, that this is an issue with the specific fonts you have installed in the project.

Thanks Flex, after your post just tried out with different fonts from FONT HANDLER.

Will pick the one which supports special characters.

 

Cheers

Vj

Share this post


Link to post
Share on other sites

I just finished a project with Spanish, French, and German libraries.  BTW - I spent more time with Google Translate than writing code!  You need to install a second copy of the fonts you will be using and be sure to "Select All" when it shows the characters available.  Unitronics' built in fonts will not display special characters, but you can install the same font and it will list it a second time at the bottom of the list.  Selecting this font set will allow you to dial in the codes for the characters you need.

 

Joe T.

Share this post


Link to post
Share on other sites

I just finished a project with Spanish, French, and German libraries.  BTW - I spent more time with Google Translate than writing code!  You need to install a second copy of the fonts you will be using and be sure to "Select All" when it shows the characters available.  Unitronics' built in fonts will not display special characters, but you can install the same font and it will list it a second time at the bottom of the list.  Selecting this font set will allow you to dial in the codes for the characters you need.

 

Joe T.

Thanks Joe.

Will explore that options and let you know the results.

 

Cheers

Vj

Share this post


Link to post
Share on other sites

BTW - I spent more time with Google Translate than writing code!

 

Joe T.

 

Darn it Joe, here I was, thinking you were a literary genius after reading your other post as well....but you've just blown it big time!

 

cheers,

Aus

Share this post


Link to post
Share on other sites

Aus - 

 

That's "literal" genius, not "literary" genius.

 

Joe T.

 

 

 

Thankyou, Sheldon!  :P

 

(And thanks for your help with everyone's issues, anyway.)

 

cheers,

 

Aus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...