Jump to content
Joe Tauser

Remote Operator on PC works but Android version does not

Recommended Posts

I am able to connect to a remote V350 on a cellular modem with the PC version of Remote Operator.  I put the same settings on the Android version and I get a connection error.

 

I am also able to see the remote PLC in Visilogic.

 

What is the network ID field for on the Android version?

 

Joe T.

Share this post


Link to post
Share on other sites

The network ID should be 0 (You also have it in Visilogic: Unit ID).

I'm guessing that an error is causing the android remote operator to assume that there is a connection error.

 

Does the android version able to connect to that PLC without a cellular modem?

Have you tried increasing the timeout?

Share this post


Link to post
Share on other sites

Hi all,

 

is there a minimum phone's screen size needed?  Once my settings are input, checking says that the connection is ok, hand is green, I can get PLC System Info fine, but it refuses to connect for the main bit.  I have only been trying this on my baby screen size phone at present, hence the question.  Will try on my bigger one later.  When I say "baby", it really is, due to bigger phones getting awkward in my often really cramped work environments.  Screen is only 432 x 240.  But it runs other things like remote videos etc. perfectly.

 

cheers,

 

Aus

Share this post


Link to post
Share on other sites

No go on the bigger phone either.  480 x 854 screen, Android 4.4.4.  Exactly the same operations, where everything connects, except the link from the green hand.  I have been trying both SIM data and wifi on both phones.

 

I have been trying adjusting length of timeouts and retries etc and have noticed something curious.  The "Connection to PLC failed" message seems to pop up after about 2 seconds, regardless of the number of timeouts or their length.

 

I've now also tried it on a FullHD tablet, and exactly the same thing. 

 

And an edit in response to Gabriel's post below....all my tries are for a remote system....will try a same LAN situation when I can and advise results.

 

Suggestions please!

 

cheers,

Aus

Share this post


Link to post
Share on other sites

So.....I set up a local 130 to try, and I get exactly the same thing happening.  I can get info, it shows the hand as green, but access via the hand then shows the connection failed message.  Everything else works fine...but not quite the same result as Gabriel.  Tried on all the android devices.  Some gliche on getting all the info.

 

I again note that there is not a delay in the message coming up that relates to timeouts and retries.  It comes up within 2-3 seconds every time.

 

All my Androids are on Avast, and I get the same result with it on or off.

 

Suggestions please!

 

cheers,

 

Aus

Share this post


Link to post
Share on other sites

Hi,

 

Just to clarify this issue,  with this mobile app you can remote access Vision Color and Samba controllers.

V130 in not supported.

 

We wish to make few tests.

Can one of you tell us on which Android version it fails to connect the PLC?

Does it failed with any application? Even a blank project? (with just Ethernet setup)

Do you have any specific project that we can test on?

 

Please advise.

Share this post


Link to post
Share on other sites

Ahhhh.  Thankyou Mr Mozes.  I have only been trying to reach 130s.

 

I have up till now not even read the quickstart pdf as the installation was all straightforward.  I've just now had a read and it is plainly there for me to see in the list of controllers that a 130 is not supported.  If only I had read it initially, but because the app is so simple I saw no need.

 

1).  I politely request that the site statement that it is available for the Vision and Samba series be modified somewhat to say that it does not work with some models.

 

2).  It is frustrating that I have spent a fair bit of time on this.  The connection was always checked as valid by the inbuilt testing, but because it is a 130 it won't reach the final step.  Yet nowhere in the app is a warning that a PLC type is not supported, if a connection is made to one.  There should be.

 

3).  If the app changes in the future to allow more models to connect, please let us all know.

 

Thanks, and cheers,

 

Aus

Share this post


Link to post
Share on other sites

Hi

I've tried to connect the app to two different V1040. Connection was unsuccessful.

I have Android 6.0.1, which shouldn't be a problem.

For me it was strange, that in the app there is no target port entry, as the PC version does.

Is there some kind of default target port set, that can not be changed?

Any ideas?

Jan

 

 

 

 

Share this post


Link to post
Share on other sites

Something very curious I have come across is that all connections to my V1210 PLC work when I am on the LAN. Remote Operator, Android Remote Operator App, Visilogic. When I am on a different LAN, all applications work well which means I have all Port Forwarding and network setup correctly. What is interesting is that when I use a 3G (on my phone) or 4G (on a different phone) network, the Android Remote Operator App can not connect to the PLC. It attempts to connect, and the PLC actually sees there is a connection established but then the Android Remote Operator App connection never goes through on the phone.

Is there some kind of bandwith or "stable connection" criteria? I thought it would have something to do with the size of the graphics cache file or something but I am reaching my limits of knowledge in this area. When I use a separate 3rd Party App (Uni Go), all connections can be made but there are not graphics in that connections, strictly reading of specific MIs and what not. 

Any ideas why the Android Remote Operator App wouldn't work over 3G or 4G but does work from a different LAN? 

  • Upvote 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...