Jump to content
Don2015

RemoteOperator w/Windows 10 Pro

Recommended Posts

Hi,

Well I have the compute stick up and running with Windows 10 Pro, I have one problem I want to have Remote Operator start on Windows Startup, when I try setting it I get an Error saying;

Attempted to perform an unauthorized operation.

I have Remote Operator set to run in Windows 7 Compatibility mode, when not set in Windows 7 mode, I get a different error that says;

Registry access is denied.

These errors are coming from Remote Operator as that is the title of the window with the error.

I am setup as administrator.

Got any ideas as to what I need to do?

Thanks,

DonH

Share this post


Link to post
Share on other sites

It doesn't matter if you are an Administrator. Since Windows 8, even if you disable the UAC, it still runs (It just doesn't show the notifications).

Writing to Registry (for having the Startup options changed) requires an elevated privileges. You need to right click Remote Operator, and select "Run as Administrator"

  • Upvote 2

Share this post


Link to post
Share on other sites

Hello,

we have a problem with the Remote Operator running on a Win10 System. When you try to open an existing project or save a project the following error appears.

The program is executed as Admin.

Does someone knows a solution to this problem?

Thanks,

 

Remote_OP_Error.png

Share this post


Link to post
Share on other sites

Thanks for your answers,

In the meantime I tried the file on an other Win10 computer. There I could open the file without problems.

I will let the customer know that he schould uninstall the Remote Operator and install it as admin.

I will keep you informed as soon this was done.

Share this post


Link to post
Share on other sites

Hello,

We also have a problem with the Remote Operator running on a Windows 10 64 bit 1809 System.
This error was not present on 1803 version of Windows 10.
We tried to run the program on another machine, running this version of Windows, resulting the same error.
The Remote Operator program is installed and executed as Admin.

As soon as we try to open or save a project, by clicking on the open/saveas icon,
the open/saveas dialog shows up, and the following exception error message appears
(this exception occours also, when we click on the "Import cache file" menu item):

Quote

Visual Styles-related operation resulted in an error because no visual style is currently active.

uni-rem-op-error-2.png.2c93ff80a22337050a70a3d3045e89b5.png

Full error message in hungarian: remote operator hiba.txt

After the error message, the program continues to work, but the upper section of its window shows no icons, and has a big red X on it.

uni-rem-op-error-3.png.e9e90c71295c1a619ff1298ec5ff90a0.png

We tried to reinstall Remote Operator, reinstall .NET framework, run the program in various compatible modes with no success.

Is there a more recent version of Remote Operator, or its development has stopped?

Does anyone have some idea, what should we try out, to fix this problem?

Reverting to older Windows version is not a soulution for us.
 

Thanks: mavika

Share this post


Link to post
Share on other sites

Does Remote Access work instead?  And did you use the Remote Operator changed dll that is in this post?  :

 

cheers, Aus

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you Ausman, for the quick answer!

We do not use Remote Access, but i installed it to try out, and its seems to work, without error messages.
(it can show open-file-dialogs, without the above exception occouring).

I changed now the Unitronics.RemoteOperator.dll to the one, that Saragani posted (from dll version 1.0.0.62 to 1.0.0.63),
but the error message still appears.

Saragani wrote:

Quote

No, it is being used by Remote Operator only, and it fixes just the trend issue.

 

Meanwhile, i found this article:

https://blog.jtbworld.com/2018/12/red-x-symbol-error-after-updating-to.html

Quote

“WinForms applications may have problems rendering the application UI and instead may render a white screen with a red ‘X’ symbol. The issue is caused by a change in Windows 10 October 2018 Update that exposed a bug in .NET Framework 4.7.2. The issue is caused by a change in Windows 10 October 2018 Update that exposed a bug in .NET Framework 4.7.2. The Windows 10 October 2018 Update adds a new flag to VisualStyle state when the application UI launches a child dialog (i.e., a FileSaveDialog or PrintpreviewDialog) that causes .NET Framework to fail its VisualStyleState check and thus throw an exception while rendering the application UI.”

I downloaded the ".NET Framework 4.8 Early Access Build 3707" and installed it, tried out the Remote Operator,
but it doesn't solved my problem.

I wonder if Remote Operator even uses 4.8 .Net framework, or instead some older, 3.5 or 2.0 version.

Share this post


Link to post
Share on other sites

You are not the only one that faced this problem, and I tried looking for the cause for this problem few weeks ago, but didn't find much of an information about it (since it was before December 26th).

Your link at least explains the cause. Now that I know what causing it, then I can try few solutions, and see if any of them works.

I hope that Microsoft will release a fix for the .Net framework that will solve this issue.

 

Remote Operator uses .Net framework 3.5. 

I have confirmed that I can also reproduce it here with Windows 10 1809. Installing .Net framework 4.8 did not solve the problem.

The link says that it's a bug with .Net framework 4.7.2, but I think it's a bug in all .Net Frameworks up until 4.7.2 (including).

 

In this case, I'm not sure if Microsoft will release a fix for .Net 3.5

I saw that Microsoft release a Windows update named KB4480056, which updates .Net framework 4.7.2 and .Net 3.5, but I tested it, and it doesn't fix this problem (it's just a security issue fix, as I understand).

In that case, I'll have to re-compile Remote Operator with .Net 4.0, so it will target .Net framework 4.8 when installed, and still be able to run on Windows XP.

I'll hope it will work. I can't say when it will be done and when I'll be able to test it.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi, I have confirmed that compiling Remote Operator so it would target .Net framework 4.0, while .Net 4.8 is installed fixes the problem.

Luckily, there is a workaround that can help you run Remote Operator with .Net Framework 4.0 and newer without getting a new Exe.

 

Go to where Remote Operator is installed, usually at:

C:\Program Files (x86)\Unitronics\Remote Operator\

 

You should find a file called: Remote Operator.exe.config

Open this file with Notepad or Notepad++ while it runs as Administrator (since you are going to change a file located in Program Files, and Windows will not let you do that unless the change is being done by a program that has Admin rights).

 

Just replace the entire content of that file (it should be a text file in an XML format, so make sure you don't accidentally open the exe file instead), and save the file.

 

<?xml version="1.0"?>
<configuration>
	<configSections>
  <sectionGroup name="userSettings" type="System.Configuration.UserSettingsGroup, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089">
   <section name="Remote_Operator.Properties.Settings" type="System.Configuration.ClientSettingsSection, System, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" allowExeDefinition="MachineToLocalUser" requirePermission="false"/>
  </sectionGroup>
 </configSections>
  <appSettings>
    <add key="EnableLogger" value="False"/>
  </appSettings>
 <runtime>
		<assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1">
			<probing privatePath="Libraries;StartupLib"/>
		</assemblyBinding>
	</runtime>
 <userSettings>
  <Remote_Operator.Properties.Settings>
   <setting name="RdpVncMode" serializeAs="String">
    <value>False</value>
   </setting>
   <setting name="AutoRun" serializeAs="String">
    <value>False</value>
   </setting>
   <setting name="ProjectLoadOption" serializeAs="String">
    <value/>
   </setting>
   <setting name="SelectedProjectToLoad" serializeAs="String">
    <value/>
   </setting>
   <setting name="StartWithWindows" serializeAs="String">
    <value>False</value>
   </setting>
   <setting name="FullScreenMode" serializeAs="String">
    <value>False</value>
   </setting>
   <setting name="AutoRefreshInterval" serializeAs="String">
    <value>100</value>
   </setting>
  </Remote_Operator.Properties.Settings>
 </userSettings>
<startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup></configuration>

 

The line that was added to the config is just after the </userSettings> and before the </configuration>.

It's the: <startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>    which tells it to target .Net framework 4.

 

 

Please tell me if it helped.

 

Thanks.

  • Upvote 1

Share this post


Link to post
Share on other sites

Hi, Saragani!

Thank you very much for the responses!

Meanwhile i have done some testing:

Without modifying Remote Operator.exe.config or installing any .NET updates, the error message says:

Quote

...
mscorlib
    Szerelvény verziója: 2.0.0.0
    Win32-verzió: 2.0.50727.9035 (WinRelRS5.050727-9000)
    Kódbázis: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
System.Windows.Forms
    Szerelvény verziója: 2.0.0.0
    Win32-verzió: 2.0.50727.9031 (WinRelRS5.050727-9000)
    Kódbázis: file:///C:/WINDOWS/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
mscorlib.resources
    Szerelvény verziója: 2.0.0.0
    Win32-verzió: 2.0.50727.9035 (WinRelRS5.050727-9000)
    Kódbázis: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
...

So for me, it looks like, Remote Operator is using 2.0 framework libraries.

I then uninstalled 3.5 .Net framework (this includes .Net 2.0 and 3.0)

image.png.2a547c7197d3587b577adc855f8ff234.png

Now when i try to start Remote Operator, it opens up a Windows dialog, complaining that the needed 3.5 framework (including 2.0 and 3.0) is missing,
and it must be downloaded and installed.  This makes sense.

After that, i have placed the line that you suggested, in the Remote Operator.exe.config file:

Quote

The line that was added to the config is just after the </userSettings> and before the </configuration>.

It's the: <startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup>    which tells it to target .Net framework 4.


So, without installing any .Net framework, i can start Remote Operator, but the "red X" problem is still there, but the error message has also changed:
 

Quote

...
mscorlib
    Szerelvény verziója: 4.0.0.0
    Win32-verzió: 4.7.3260.0 built by: NET472REL1LAST_C
    Kódbázis: file:///C:/Windows/Microsoft.NET/Framework/v4.0.30319/mscorlib.dll
----------------------------------------
System
    Szerelvény verziója: 4.0.0.0
    Win32-verzió: 4.7.3314.0 built by: NET472REL1LAST_B
    Kódbázis: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System/v4.0_4.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Windows.Forms
    Szerelvény verziója: 4.0.0.0
    Win32-verzió: 4.7.3260.0 built by: NET472REL1LAST_C
    Kódbázis: file:///C:/WINDOWS/Microsoft.Net/assembly/GAC_MSIL/System.Windows.Forms/v4.0_4.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
...

Now its using 4.0 (4.7?) .Net libraries. 

After that, i installed  .NET Framework 4.8 Early Access Build 3707 found here: https://go.microsoft.com/fwlink/?linkid=2032091
 

Doing so, the "red x" problem is solved! Your workaround is successful!
 

I can now confirm, that to solve this "red x" toolbar problem, it's needed to do 2 things:

1. put the <startup><supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.0"/></startup> line in the Remote Operator.exe.config file, AND
2. install the Microsoft fix: .NET Framework 4.8 Early Access Build 3707 https://go.microsoft.com/fwlink/?linkid=2032091

Perhaps, Microsoft will release an update via Windows Update once also.


Thank you again Saragani for your help!
 

--------------------------------
Note: this above issue has nothing to do with the other "red x" problem on the plc image, caused by the missing cache files:

 

Share this post


Link to post
Share on other sites

I installed the Microsoft fix and modified the .config file on another 3 machines, which also had this problem.

This solved the issue on all of them. 😄

Share this post


Link to post
Share on other sites

My windows version was updated and I now have windows 10 version 1903

 

I'm unable to reproduce the problem on my new windows. Can anyone verify if this problem is fixed on the new windows version?

 

Share this post


Link to post
Share on other sites

I'm currently shifting a number of older puters up to 1903 via upgrade from iso, not clean install.  I have another newer one that is always a clean install.  These normally aren't involved in Unitronics stuff, but I'll try on a few once done and advise.

cheers, Aus

Share this post


Link to post
Share on other sites

@Saragani I have now upgraded 2 systems to 1903 that have never had Unitronics stuff.  Loaded RO onto both and it worked fine accessing my 130s.  I don't know about more complex Visions as I have none to try it on.  Also remember that both the puters were not clean install, they have always been upgrades from when shifted to W10 from W7.  I have yet to do the clean install, this could be a few weeks away.   Will advise once done.

cheers, Aus

Share this post


Link to post
Share on other sites

I can confirm, that with the recent Windows version the red-X-toolbar .NET problem is fixed.

Yesterday, i made a clean install of Windows 10 Pro 64 bit Build 1903 ,with Microsoft Media Creator Tool made USB stick.
(Full reinstall, not just update, i choose at install, to delete all partition and recreate them.)

After drivers and windows updates installed, i tried to install Remote Operator 1.0.71.

It shows up a dialog, it requires the .NET Framework version 3.5, clicking yes opens browser at dotnet.microsoft.com.

remote-operator-requires-netframework35.png.e6dc9d30dd44f584b83a27e1e3dab282.png

I do not downloaded anything, instead opened program-components in Windows, clicked the 3.5 Framework checkbox, and let Windows to install it.

image.png.2a547c7197d3587b577adc855f8ff234.png

After that, restarting the Remote Operator installer runs succesfully, and the program works normally,
it can connect to V130, V570, V1040 PLCs.

The open and saveas dialogs also works, the big-red-toolbar problem is not present.

Share this post


Link to post
Share on other sites

Something to remember:  if you update Windows through Manual Update, per Microsoft, you have agreed to upload anything in any state whatever, including beta files.  The user is not notified by Microsoft of this but they did admit to it earlier this year / end of last year.  "Official" Microsoft updates are pushed to PCs.  None of my personal computers have 1809 since it was not pushed.  Microsoft admitted that it has lots of problems.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...