Jump to content
Sign in to follow this  

Gadner Denver Compressor Com Module

Recommended Posts


Trying to connect to a Gardner Denver   Airsmart  Controller Comm Module.

Serial Interface - RS232  works.

Trying the MODBUS  TCP  UDP  protocol on their ports 2000 and 2001 - no luck yet,  we can ping the IP OK, just no connection for

MODBUS Read Registers(3)

Any one had experience with this unit?




Share this post

Link to post
Share on other sites

I am having a similar issue. Using Prosoft Modbus Ethernet card for compactlogix and Gardner Denver AirSmart Controller Comm module.

I can ping the comm module, but I get a error code -48 when I try to read from the module. It is the same error as if it was not connected at all.

I have tried different cables, and bypassing the ethernet switch.  What else do we have to do with the AirSmart comm module other than enter the IP address, subnet mask and gateway.


Share this post

Link to post
Share on other sites

For these tasks, a reliable modbus simulator for PC is absolute priceless thing. If you are in doubts, the first task is to check the setting with simulator. It is much easier to find problems if you can change the communication parameters interactively "on the fly" without changing, compiling and reloading PLC program. When the device communicates with PC without bugs, then it is the right time to start comunicate from PLC. 

Good luck,

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this