Jump to content
chrobakpeter

JAZZ PID Autotunne

Recommended Posts

Hi, Confirm you perfromed the following procedure:

  1. 1. At Power-up, SET SB109 ON.
    2. Enable the PID output (for example, if you used MB0 to enable an HSO, turn MB0 ON).
    3. Activate the Run PID MB for the loop you want to tune.
    4. Turn the appropriate Start auto-tune SB ON; activating the auto-tune function.

  1. 5. When auto-tune is complete, the SB will turn OFF, and the appropriate auto-tune is Complete SB will turn ON.

Share this post


Link to post
Share on other sites

Hi 

Can someone help me with the same problem with autotune,  I use JZ20-J-UA24 and  I control temperature with SSR on transistor Digital Output. I try with SB109 and SB101 nothing happends. I also try with  PID server it run 2,3 hour and also nothing.

I also sending you the file of the program if you need it.

 

Thanks

Aleksandar

Fantazija Pakerka20171116.U90

Share this post


Link to post
Share on other sites

Hi Kikis

Thanks for your help. I try that and when Auto tune finish it change the Kp, Ti and Td, but when I start the pid loop the temperature rich more then set temperature.

Does before I set SB101 I should start the PID Loop for example in my case MB0, Because I do that and after finishing the temperature variate -/+2'C?

 

Aleksandar 

Share this post


Link to post
Share on other sites

Hi AleksandarVin,

 

If you follow Stein Yair's instructions given in a previous post in this topic, it should work.

In your case, steps are like this:

 

1) At power-up  SET SB109 ON

2) Turn on MB0

3) Turn on SB101

Share this post


Link to post
Share on other sites

I have found that Auto tuning doesn't always work well, regardless of the vendor.   

Some processes require a manual touch.

Your best option is to do some research on the Internet on loop tuning so you understand what the algorithm is supposed to do and how changing the parameters affects it.

If the variation is big it means your P value is too small.

Joe T.

Share this post


Link to post
Share on other sites
1 hour ago, Joe Tauser said:

I have found that Auto tuning doesn't always work well, regardless of the vendor.   

Some processes require a manual touch.

+1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...