Jump to content
Sign in to follow this  
alexmoskos

Using PT1000 with UIS-WCB1

Recommended Posts

Hi,

I already have a couple of PT1000 temperature sensors that I would like to use with  the expansion module UIS-WCB1 but the specification says it can only work with PT100 (and other thermocouples) but not PT1000. The temperature range this sensor will ever see is between 0-100 C. Because of this relatively smaller temperature range, would I be able to use the PT1000 sensor with this I/O module, by writing some code to account for the difference, instead of having to purchase the UIS-04PTKN module?

Share this post


Link to post
Share on other sites

Look at these resistance tables-

100 ohm RTD

http://www.pyromation.com/Downloads/Data/385_c.pdf

You'll note the highest reading is 390 ohms at 850 C

1000 ohm RTD

http://www.thermometricscorp.com/PDFs/Platinum-1000-Ohm-385.pdf

All the values are increased by a factor of 10.

 A 100 ohm input will totally barf if you connect a 1000 ohm load to it.  

Joe T.

  • Upvote 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...