Jump to content
Sign in to follow this  
SvjatoslavsKrasnikovs

Time logging problem

Recommended Posts

Hi,

I am facing troubles while trying to log and later display time using Jazz2 controller. So, I'm trying to make an error log. When the error occurs I store current content of SI31 (RTC time) to MI (MI33 in this case - so far it's working). Then in order to display the error I pass MI33 content to MI41 (MI41 is linked to Time Function variable (in CT format) that is then displayed on HMI) . You can see the whole process in images below. The problem is that in the end, the content of MI41 (decimal 1500 - which I corresponds to 15:00 time) is then displayed as 05:DC on the HMI display. I guess the problem is caused due to DEC/HEX conversion. Any idea how to fix this ? Thank You.

 

 

1st.png

2nd.png

3rd.png

4th.png

Share this post


Link to post
Share on other sites

My first thoughts are:   have you trialled different variable types in the HMI settings?  Can you also do a screenshot of the related variable window?

cheers, Aus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...