Jump to content
Sign in to follow this  
Garry

Info/calibration screen issue

Recommended Posts

We have a V570 that has been in use in the factory that suddenly  jumped to the Info screen while in the middle of the program.  The technician touched the screen calibration button and the target just keeps jumping around before it is even touched. We tried restarting the unit, but it does the same thing.  Anything we should try or has this unit failed?

Share this post


Link to post
Share on other sites

Hi Garry

I have changed the front part of the V570 before.

It is quite an easy repair and the part was quite cheap.

The part quoted was "SA/V570-FRONT" Im not sure if this is the official part number or just our unitronics suppliers number.

If you contact your spplier they should be able to advise you.

Regards

Denis

 

Share this post


Link to post
Share on other sites

I am having the same issue. Where could I get that screen cover? our supplier says he cant get that part. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...