diogki

Water meter - flow peaking

5 posts in this topic

Hello.

I encounter a problem and i would like your help fixing it.

I have a v1210 PLC , one EX-D16A3-RO8 and one snap-in module V200-18-E6B.

I have connected two flow turbines to the two HSC inputs of EX-D16A3-RO8 and the other two flow turbines to the two HSC of V200-18-E6B.

In hardware configuration i have linked MI0 and MI1 to the two turbines of the snap-in module. MI2 and MI3 are linked to the two turbines of the EX-D16A3-RO8 module. Every 10 seconds i multiply every HSC MI by 360 (10x360=3.600 seconds = 1 hour) beucause i need the flow in lt per hour (you see 36000 and not 360 because in the division the factors normally  have two decimal digits, so i multiply by 100 and remove the decimal point). Then i divide with the Kv factor (according to the turbine manual - Kv is the amount of pulses for every lt) and the final outcome is the instant flow.

The problem is that while the flow from two turbines that are connected to EX-D16A3-RO8 are not peaking, the two turbines that are connected to V200-18-E6B are peaking every few seconds from 4.500lt/h to 12.000-13.000lt/h and back again to 4.500lt/h that is the real flow.

I have checked the turbines and they don't have a problem.

Maximum input is 1.000 pulses every second.

Are there any suggestions?

Thank you in advance

un forum.jpg

0

Share this post


Link to post
Share on other sites

I'd initially be splitting out your operations in 75 into smaller blocks.  Let us know how that goes.

cheers, Aus

0

Share this post


Link to post
Share on other sites

Thank you Ausman for your reply.

I have already tried this but it didn't work.

I have tested one more module (IO-DI8-RO4) that has one HSC, assigning MI0 from the snap-in and the problem didn't appear.

Now i have 3 flow meters operating normally ( two on EX-D16A3-RO8  and one on IO-DI8-RO4 - both set to HSC with Reset in HW) and one that is peaking on the snap-in V200-18-E6B.

I think that the problem is with the snap-in. In HW Configuration the setting of the HSC is "HSC with Reset - Odd input high".

0

Share this post


Link to post
Share on other sites

Hi diogki,

Ausman is right about complicated net.

1.Better is to modify it as follows:

Y4pWcraDVtwAAAABJRU5ErkJggg==

2.Snap-in allows to reset HSC, as communication to snap-in module is fast.

Communication to expansion module is slow, this is why you cannot reset counter, located at expansion module.

You have to use virtual counter. *MI 0 is linked to HSC in Hardware Configuration.
 

cid:image001.png@01CDC326.B9A58B20

I believe, that peaking is result of counter reset, which at next scan overwritten by data, received from expansion module.

Best regards.

0

Share this post


Link to post
Share on other sites

Thank you both for your replies.

Using Virtual HSC Reset solves the peaking problem.

I thought reseting via the reset input of the modules would be better...

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now