Jump to content
Juandiaza

Not connection between SM43 PLC and APP

Recommended Posts

I don't know What I am doing wrong but I can't connect my PLC via Remote Operator. I did it as help said 

image.thumb.png.466ff213059f3f77e323b5c268cffd3c.png

My IP address is 169.254.240.14

image.thumb.png.f5e527a403158a51714bbca79d4df7f6.png

Socket 1 and Port 20256

image.thumb.png.86f2ad0f7328b2c2887f82d9811a1465.png

over the App I set up like this

remote_operator.thumb.png.d89c4acc41dc985a7f976d74272b6e93.png

But when I Check PLC Connection said "Connection to PLC Failed"

Any suggestions for this????????

Thanks in advanced  

1

Uploaded Images

  •  
  •  
 

image.png

132 kb · Done

  •  
  •  
 

image.png

122 kb · Done

  •  
  •  
 

image.png

121 kb · Done

  •  
  •  

Share this post


Link to post
Share on other sites

I've got your post looking a bit odd, seeming to have more photos but not visible, so perhaps my question is in there.

Have you got your router ports/permissions set correctly?  You won't get in if the router is stopping you.

cheers,

Aus

Share this post


Link to post
Share on other sites

You must set PLC name in rung 1 at the right of FB's you already have. APP will not work with no PLC name defined in ladder. Name is your password of sorts, I would suggest making it something more unique than SM43 if it is going to be port forwarded to the public internet. Another note: socket 1 is set to 20256 by default. While redefining socket does no harm, it is not required. Happy coding. -dB

V430example.JPG

  • Like 2

Share this post


Link to post
Share on other sites

Hi,

IP address 169.254.240.14 is from 'Automatic Private IP Addressing" group 169.254.xxx.xxx.
IP Address from this group is assigned, when DHCP enabled, but IP address cannot be obtained from DHCP server.
IP Addresses of this group are not routed. You can make connection only  on the same LAN.

I recommend you to use any WiFi router with LAN port and assign to PLC IP address  from available  router IP addresses.

Enable WiFi at your phone and connect to router.

Now you r phone should be at the sime subnet as PLC, and you will make connection.

Allow to download cache file to smartphone  , then you can use Remote Operator.

I hope this helps.

 

  • Like 1

Share this post


Link to post
Share on other sites
On 9/16/2017 at 12:07 PM, Juandiaza said:

Yes, my phone is running on the same subnet? 

I disregarded IP address range because of quote above. I guess that's a statement, although it does end with a question mark. I thought that address looked like Microsoft's "dummy" address. Any two devices on the same physical LAN and common subnet should be able to communicate. I didn't see or confirm the IP address the phone had obtained. 169.254.x.x is not an address pool I would expect to see in a DCHP router. It would be a good measure to put router, plc,  and phone in a more traditional address pool like: 192.168.x.x or 10.0.x.x

I have an app on my iphone called "ping lite" that runs IMCP ping command. Very helpful in determining if basic network communication is working between phone and other device (PLC in this case). 

  • Like 1

Share this post


Link to post
Share on other sites

Juandiaza,

Please check IP address, assigned to your phone.

Exact settings location depends of your phone model.

For my Android devices it is in "Settings->About Phone/About device->Status->IP address".

Is this address at the same network space as PLC - 169.254.240.xxx?

If yes - extend PLC Subnet Mask to 255.255.0.0, and test again. *Do this from Info Mode first.

If not, you have to change IP network settings to one of standard settings -

Share this post


Link to post
Share on other sites

Hey guys, I got a success connection between my PLC and yhe Apps after several times. What I did was get all the info through Command Prompt and use the IPv4s Address in this case was 192.168.0.7 (preferred) and set up on computer and my phone and was able to communicate each other using the same LAN. I tried to connect using different LAN it won't work. 

Thanks to all for your useful comments. It help me a lot. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...