Jump to content
D Green

FTP client won't connect to UniStream FTP server

Recommended Posts

Here's my server setup (Password is Pass99.):

FTP_server_setup_112017.png.964f7aa9c0b07681e434c06444e878f2.png

 

Here's what happens when I try to connect using FileZilla:

Fz_screen_111717.png.efd6a15c9af91d2c2d9de174a3a5c039.png


Here's what happens when I try to connect using the Windows FTP client:

cmd_prompt_ftp_111717.png.f82327e1733baaeda9c1916e1d370445.png


When I first used FTP, it worked. Then I didn't use it for about 3 weeks. After that, I got this problem. During that time, I changed nothing except my project file (ladder and HMI changes). I tried an older project file from before the problem occurred and still get the problem. I also tried connecting from a different PC - still no luck. Someone suggested running the client as administrator. I'm running an admin account on both PC's.

Any ideas?

Share this post


Link to post
Share on other sites

Hello,
We are not familiar with such issue.
Which firmware version is installed on UniStream? Did you try to cycle power the UniStream? If after power cycle it still cannot connect then send a mail to support@unitronics.com with the application and we will try to test it here.

Share this post


Link to post
Share on other sites

I think that the best option in this case is to investigate the issue in the PLC with a remote session (So the Panel team would be able to find / understand why it happened, and also fix the problem that prevents your PLC from establishing an FTP Server).

BTW, did you try doing a "Download All"?

Share this post


Link to post
Share on other sites

Download All and a blank project didn't help and so has Power cycle the PLC many. However, I was contacted by Unitronics headquarters (remote session) about this issue. A remote session was done from there and the problem was solved.

They found an issue with username/password control and said it can cause a problem once in a blue moon. If it ever happens again, the remedy for  a user is to reinstall the UniStream OS. They said this will be corrected with the next OS version.

To Eduardo and everyone else involved: Thanks for your help. A definite reason for us to stick with Unitronics.

Share this post


Link to post
Share on other sites

Happy to help.

Just to elaborate on D Green comment. The issue is a wrong internal logic on the  username/password mechanism.  It exist until OS version 1.22.X but not likely to happen (the combinations of terms to it to exist is rare). This issue will be fixed in version 1.23.X.

Workaround - Force upgrade the UniStream OS.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...