Jump to content
Sign in to follow this  
sasdiscos

Remote over 4g

Recommended Posts

Hi everyone.

 

Hoping some one can help. I can't get my remote app on the iPhone to connect to the plc over 4g. In the house, it will connect over the wireless to the phone and work fine. Out the house and nothing. I have cctv connected the the same router and this app connects fine over 3g 4g and when on other wireless networks. This makes me think that all my router permissions are correct.

 

Any one?

 

Many thanks in advance, Steve

Share this post


Link to post
Share on other sites

Hi sas,

just because your cctv works doesn't automatically mean the plc is correct in the router.  There are various ways of doing things, and different brands of router have their own quirks. Have you done specific port forwarding on the correct port?  Have you done anything else your particular router needs to do to let the used port in and out of your system?  You generally have to have a specific setup for plc comms.  And what plc are you using?

cheers,

Aus

Share this post


Link to post
Share on other sites

Hi, thanks for the reply.

Its a v350 connected to an sm45 via modbus. I can connect to both in the house. I went through all the settings but maybe i need to check again. I assumed it would be the same permissions as the cctv.

 

Steve

Share this post


Link to post
Share on other sites

Dear Sas,

if you have two machines connected to one gateway,  things are getting little more complicated. Because your router does not know which PLC you like to connect to, you must distinct them by using different TCP ports. You can use port 20256 for the first PLC and 20257 for the second one. Be sure these ports are properly initialized by Socket Init FB on appropriate PLCs.
Next task, make your router to divert call from WAN on port 20256 to the first PLC and call from WAN on port 20257 to the second PLC. You can use next screenshot from my router as an idea (Private IP should be replaced with your LAN address of the first PLC; then do the same for 20257 and second PLC LAN address as well). 5ab8aa3aa48d3_NATobrzek.thumb.png.093a9100642d46570cac73ccd125f917.png

If you have these jobs done, you can use your Remote Operator from the smartphone. Use the public WAN address of the router on port 20256 for the first PLC and the same WAN address on port 20257 for the second one.

Share this post


Link to post
Share on other sites

Hi stembera, yup, done all that before, Ive just been back through to check all my settings  and still nothing! Im guessing its something to do with the sky router. Strange that i can fully access it over my wifi but not 3g. It has to be the sky router blocking it from external access. 

 

Steve

Share this post


Link to post
Share on other sites

Hi Steve,

does your ISP have you on a static address?  I'm also not clear on whether your router is connected to the outside world via landline, or this is the 3G connection you are speaking of.  Describe the full path in order please.

In our neck of the woods, a particular segment of the route that involves using a sim needs one dedicated to handling data.  Which often means way more expense unless you use one of the "fixed small amounts of data" types available through specialist resellers.

cheers, Aus

Share this post


Link to post
Share on other sites

Its a sky router connected to the phone line. I don't know if i have a rolling ip or not. I wouldn't have thought so. The pics are connected through that. I also have a bigger router off this to serve all the other bits in the house.

 

If i connect another v350 directly to the router with the incoming internet i still can't connect via 3g. I set the ports as described on the sky site and what I've read online. Ive even tried disabling the firewall on the router completely. 

 

I have read somewhere that its could be sky. I just can't work out why the cctv works fine, no adjustments made at all for that. Just plugged it in and it worked, over wifi and then on 3g. PLC just connects on wifi.

 

Steve

Share this post


Link to post
Share on other sites

ignore the names on the setup, I've just pasted the wrong one in when trying different plcs on my network, the port forwarding matches the setup.

Share this post


Link to post
Share on other sites

Many camera systems these days connect to the outside world in unusual ways, to let people use them without needing to go into their router too much...if at all.  There are many that communicate through a master server, which I intensely dislike from a security point of view.  (my same thoughts on IoT...I reckon that's a nightmare about to happen).

In my routers I also have to set up other areas to allow the plc to communicate, one in particular is telling the router that the plc is a server.  Have a really good look through everything the router has in its options.  Different brands of routers don't use the same names for the same functions.....grrr......so investigate everything thoroughly.

Can you try the plc on another system that uses a landline for WAN?  That might show whether your "sky router" is at fault or not.

cheers,

Aus

Share this post


Link to post
Share on other sites

Hello Steve,

as Ausman said, cameras often have its own cloud technology which is bridging your router NAT (like Skype or TeamViewer). Maybe it is your case because there is not NAT record for camera system on your router screenshot. 
Are you sure your router has an public IPv4 address? Check this on WAN status page of your router. It should have true public WAN address (it must not be like 10.x.y.z or 192.168.y.z or 172.x.y.z). If on doubt, try to ping to your router WAN address from somewhere outside of your LAN. Does Ping work? If not, run tracert command from your LAN to some well known public address in the internet. (e.g. Google DNS 8.8.8.8). The tracert record should show only one jump from LAN to WAN and it must go through your router as the only gateway between LAN and WAN.
3g / 4g routers have very often only LAN address as they are part of the wireless LAN of the nearest BTS. In that case you will need to ask your provider for public WAN address or you will have to use another service (TeamViewer).

regards,
Michal.

Share this post


Link to post
Share on other sites

Thanks guys, why is every thing so difficult? I think its a sky thing. It getting  bit complicated. Ill have one more try, shame as it would be really handy to turn my heating on from out side the house.

 

Steve

Share this post


Link to post
Share on other sites

I repeat to try it on another network that uses different methods as the definitive test.

I've also done a comment about this in The Lounge.

cheers,

Aus

 

 

Share this post


Link to post
Share on other sites

Also, you have a pretty pic up there of "Inbound Services".  You should also have something set up in "Outbound Services"....if it exists!

cheers,

Aus

Share this post


Link to post
Share on other sites

I can't seem to find specific WAN settings with reference to the public ip apart from this. I did try and set it up but it still didn't work.

 

 

Screen Shot 2018-04-04 at 07.27.13.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×