Jump to content
kolya_asu

UNIOPC + Modbus RTU (COM port)

Recommended Posts

Hello. I am forced to ask you for help, as I spent a lot of time trying to solve this problem on my own.
I just can’t connect PLC V350 Vision with OPS server UNIOPS + SCADA.
By TSP IP I managed with great difficulty to establish a connection with this controller (nowhere did I find an intelligible, complete description of the connection), but now this is not about it.
I tried various options, but nothing works. I enclose screenshots for clarity, can someone tell me what else I need to do in order for the VISION PLC 350 to see the OPS server. I would be grateful for any help. Thanks. . The original RS232 cable, 100% working!

FOTO_0.png

FOTO_01.png

FOTO_02.png

FOTO_00.png

Share this post


Link to post
Share on other sites

My initial look has me worrying about the message at the bottom of a number of the screenshots.  Incompatible hardware config........It appears that you have a different model in use in your program to the actual plc.  Try rectifying this first and see what happens.

cheers, Aus

Share this post


Link to post
Share on other sites

Incompatible hardware configuration (slightly different) ... Yes, indeed, the PLC is different in the configuration. I have a model V350-35-TU24-IT. I just changed the configuration of harware to the nearest model V350-35-TA24, since it is *** TU24 that does not exist at all. Nothing has changed, the connection with the OPS is not installed. I do not think that the problem in the configuration of harware, according to the TSP IP works the same. What could be more?

Changed a bit the initialization of COM1 and the inclusion of MODBUS EX. The result is the same - no connection is established with UniOPS.

MOD_1.png

Share this post


Link to post
Share on other sites

Yes, I did everything as stated in the UniOPS instructions. I said that if I configure the OPS and the program in the PLC to work on Modbus TCP-IP, then everything works fine for me, but for some reason, the СОМ-port doesn’t want something !?
Maybe there is a problem in the sequence of location of the FB blocks?

Share this post


Link to post
Share on other sites

I have never personally used the OPC server so I can't speak from direct experience, but I did look at the OPC manual.

The OPC server is a program that has been around for a long time, and I don't think it uses Modbus.  I didn't see anything in the manual about setting up the PLC as a Modbus slave.  The OPC Server probably uses the Unitronics PCOM protocol, and by using the COM INIT block and Modbus Config in the ladder logic you blocked the port to PCOM commands.

As an experiment, try deleting COM INIT and the Modbus Config block if you still want to try it.

Joe T.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Try removing the MB0 inverted contact from rung 3.  And I thought that those times relate to the update rate.  Sorry for not helping much.....I haven't done this for ages, and even then it was just an experiment.   cheers, Aus

Share this post


Link to post
Share on other sites

This was bugging me so I asked support.  Here is the response - 

Quote

 

Hi Joe,

Thank you contacting Unitronics.

UniOPC is just going to be the bridge to the PLC. A connection will be made very similar to how its made in Visilogic. 

A more robust means of communication is actually using Modbus, if the client package has a driver available.

Please contact us with questions!

 

So UniOPC does use PCOM.  You would want to remove the Modbus logic if you're using UniOPC to a Unitronics PLC

image.png.c2e92b942c7176e48d72b582560565c4.png

This is a muddy part of the Help.  It is referring to an OPC server provided by somebody else (such as Kepserver) that uses Modbus as its protocol.  Also known as a "Modbus OPC Server".  This is not what UniOPC is.

 

image.png.7aae512ce1a39a838c6e94021f90e415.png

This is their way of telling us not to call Modbus continually from ladder logic if the Unitronics is the Master.

The times are bases on the PLC model.  Don't use 0.0 time.  I can tell you from experience that you have to wait a bit between slave calls - I usually wait 0.1 seconds.

Joe T.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...