Jump to content

Recommended Posts

Dear sir,

I'm trying to communicate tcp/ip (Valves)with v700 unitronics.but communication not yet done pls provide solution  to resolve.I have attached ladder for your ref

20181130_111922_030.jpg

Share this post


Link to post
Share on other sites

We need to see inside those function blocks to provide any meaningful help. Post your .vlp file. Alternatively, you can review the example projects that came with your VisiLogic installation. They show the proper way to set up MODBUS TCP communications.

  • Upvote 1

Share this post


Link to post
Share on other sites

Dear sir,

I have attached my sample tcp/ip program. For your reference.I'm trying to connect three different ip in one master V570.Kindly check and provide solution for that.Thak you for your earlier replay.

 

Share this post


Link to post
Share on other sites

In net 2 you have Socket 0 Connect four times to different IP addresses.  You can't do this - the socket can only connect to one at a time.  And you have to close the socket each time.

You should also use a positive transitional for this, as the Socket won't talk while it's Connecting.

It looks like want to talk to the valves every 5 seconds.  You also don't have a coil for MB 435 Socket 0 Close. 

You may need a short delay (0.1 s) before switching IP addresses to another valve to let the Modbus finish.

I put this into one of my State Machines as this is what I do for fun on a Saturday night and this is a good example for other users.  The pointer / Equal block method allows more control.

I did this in VisiLogic 9.8.79.  Let us know if it works.

Joe T.

 

 

sample1040tcpip JT.vlp

  • Upvote 1

Share this post


Link to post
Share on other sites

Thks a lot Joe...I just now download this program and sucessfully got communicate with 3 different Ip Device. So what here happn in 5 sec only device will ON after its getting cummunication got fail.it will repeat again and again how can I hold my communication permanent.

Share this post


Link to post
Share on other sites
On 12/2/2018 at 6:22 AM, Tech said:

So what here happn in 5 sec only device will ON after its getting cummunication got fail.it will repeat again and again

I'm not understanding what you're saying here.

Joe T.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...