Jump to content

Recommended Posts

please i downloaded my program to my plc V1040 and its not displaying.  It is just blinking. i tried updating the OS and still didnt show and also i entered the info mode but still not displaying. please what can i do to solve this problem?

what can i do to make my screen display my program?

Share this post


Link to post
Share on other sites

Did you, by accident, write values into registers for LCD control, you can see this when you connect to PLC.

Also, I had similar blinking was I just placed "set string library" function block to be called unconditionally in every scan. See what happens if you put PLC into stop mode. What is scan time?

Share this post


Link to post
Share on other sites

1-st - load to panel empfy project.

2 - find and  load project for V1040 from example for test the panel hardware.

3 -If display blinking you maybe use for change display direct contact   -| |-, but only -|P|- must be used. 

Share this post


Link to post
Share on other sites

Hi;

How are you calling HMI's to display?   Use    --|P|--     to call displays from ladder.

Post your code, we can take a look.

 

Dan

Share this post


Link to post
Share on other sites

Wow!  It must be Christmas with everyone full of goodwill!  All good suggestions there! 

And I notice Isakovic must have been having a hard time at the computer with the change of avatar. 

cheers, Aus

Share this post


Link to post
Share on other sites
6 hours ago, Ausman said:

And I notice Isakovic must have been having a hard time at the computer with the change of avatar. 

I saw that, too!

17 hours ago, berkaykaya said:

Can you send your program?

I'm sticking with this one.  Post your code.

Joe T.

Share this post


Link to post
Share on other sites
7 hours ago, Ausman said:

And I notice Isakovic must have been having a hard time at the computer with the change of avatar. 

It'll be better. That is my troubleshooting face.

:mellow:

  • Like 1

Share this post


Link to post
Share on other sites
8 hours ago, berkaykaya said:

I add first scan display codes at your program.

This codes make every first scan load -Main Display-

I think when you look codes you will understand "what i wanna do" :) 

alagbawale-BK.vlp

Have a nice day!

Thanks very much but i tried this but not still working. its still flicking.

 

Share this post


Link to post
Share on other sites

Your both constantly calling the main display which is what is causing the screen to flicker. 

See net 1 in the original program, every time the PLC  scans the logic it is going to load the Main display. (In a Vision unit we are talking every 4-5 mS) You can remove this net.

Also while net 2 works you should have it broken into 4 separate nets. Nets 7,9,11,13,16,18 in the Main routine should also be separated in to multiple nets( you can get abnormal operation with the way you've done it)  I didn't check the other subroutines but any where you've done something similar should be broken in to multiple nets.

And why are you calling the displays from the ladder using MB's linked to touch properties??  If you click on the Links & Jumps tab while editing an HMI you can put your display calls there and not have them in your ladder.

 

Share this post


Link to post
Share on other sites
On 12/19/2018 at 5:23 AM, kratmel said:

3 -If display blinking you maybe use for change display direct contact   -| |-, but only -|P|- must be used. 

The third post in this thread provided your answer which you either missed, ignored, or didn't understand.

To be clear, NEVER call an HMI screen with a direct contact. You MUST use a transition contact - always.

Also, please restrict your ladder rungs to only a single logic thread. One logic thread = one ladder rung. Do not stack them up. They will often work, but it can be unpredictable.

Avoid conditional subroutine calls.

Avoid HMI screen calls or subroutine calls with other logic in a ladder rung (i.e. other coils or FBs).

  • Like 1

Share this post


Link to post
Share on other sites
26 minutes ago, Cam said:

Your both constantly calling the main display which is what is causing the screen to flicker. 

See net 1 in the original program, every time the PLC  scans the logic it is going to load the Main display. (In a Vision unit we are talking every 4-5 mS) You can remove this net.

Also while net 2 works you should have it broken into 4 separate nets. Nets 7,9,11,13,16,18 in the Main routine should also be separated in to multiple nets( you can get abnormal operation with the way you've done it)  I didn't check the other subroutines but any where you've done something similar should be broken in to multiple nets.

And why are you calling the displays from the ladder using MB's linked to touch properties??  If you click on the Links & Jumps tab while editing an HMI you can put your display calls there and not have them in your ladder.

 

Thanks so much but Please i dont understand what to be done, can someone just kindly help me edit this program to see where i made the mistake.

Share this post


Link to post
Share on other sites

By the way... in future...

Do not rename the main display when you start a new project.
Never wipe the main display out of the project - this leads to incorrect order of display on the screen.

And this can not be fixed by creating a new main display.
This feature was studied by my students.
After wiping the main display, they were not able to restore the normal sequence of opening display at startup and must  to completely redesign the project from an empty project.

P.S. In your project this isue not appear.

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...