Jump to content

Recommended Posts

Hello,

 

I'm using the Samba to control a simple servo.

It works with the step control hso.

Everething works ok , only it is not possible to make a homing cycle.

How can i reset DW0 in the file included ?

I can't do anything with this operand.

There must be a solution because when there is no homing you can't use the stepper function to positioning ??

test stappenmotor.vlp

Share this post


Link to post
Share on other sites

Can't you use Store/Direct to put 0 into DW0 when at the home point?  I also note that in a very quick look at your program that you have DW0 power up value set at 0.  There are pros and cons to this, retaining the value might be beneficial.

cheers, Aus

Share this post


Link to post
Share on other sites

I can't run your program as I don't have a Samba.  And I don't normally play with steppers so this is new to me too.  From what you are saying it would appear that because the hardware config is told  DW0 (in your case) is the count, then there is an automatic system lock on it being changed through normal methods.  In this case I would have thought there was a reset SB/MB somewhere, but not found.  Have you tried "Reset Numeric"?  Or include it in your display with a numeric entry possible?

Someone else chime in who actually knows?  Pretty please!

cheers, Aus

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...