Jump to content

Recommended Posts

Hi all,

Just updated a piece of Visilogc software and I am now getting the following error:

image.png.13f7cb6d08a4fa98cb51a9c2039650d2.png

Does anyone have any idea why this has happened and how can I get out of it? 

Thanks in advance!

Jon

Share this post


Link to post
Share on other sites

I believe support@unitronics.com can roll back the database of the project if you don't want to use the beta version email them a copy of the program.

Share this post


Link to post
Share on other sites
16 minutes ago, Flex727 said:

Database 154 is from VisiLogic 9.8.79.

Database 153 is from VisiLogic 9.8.65.

Thank you for your reply,

This is interesting, I actually don't have .79 installed, only .65.

However I have been doing some work with the Data Table Editor in the SD Card Suite. Could this have caused the issue? Or is it referencing a different database entirely?

7 minutes ago, Cam said:

I believe support@unitronics.com can roll back the database of the project if you don't want to use the beta version email them a copy of the program.

Thanks for the reply,

I'll give .79 a go then.

Jon

Share this post


Link to post
Share on other sites
1 minute ago, Jon1711 said:

However I have been doing some work with the Data Table Editor in the SD Card Suite. Could this have caused the issue? Or is it referencing a different database entirely?

Different database (to my knowledge).

2 minutes ago, Jon1711 said:

This is interesting, I actually don't have .79 installed, only .65.

Has the project file been opened (and saved) by anyone else?

Share this post


Link to post
Share on other sites
4 minutes ago, Flex727 said:

Different database (to my knowledge).

Has the project file been opened (and saved) by anyone else?

Ok, thanks again for your replies,

Nobody else had opened it, however one of my colleagues had tried to install the BETA version a week or so ago and it failed (!!), I believe this may have overwritten some .dll or install files but never fully completed the install.

I originally opened the project successfully (v2.0.6) --> did a 'save as' --> renamed the file (v2.0.7) --> then couldn't open the new file due to a database mismatch...

It also meant I couldn't uninstall / modify / repair the Visilogic software as the installer files were the wrong version and the PC threw back a 'catastrophic failure' (drama queen).

I have another PC with Visilogic on and successfully uninstalled .65 and installed .79 and now I can open the new file. Perfect!

I have a feeling I will have to wipe the laptop and reinstall everything, luckily it is only really used for Visilogic programming.

Jon 

Share this post


Link to post
Share on other sites
4 minutes ago, Jon1711 said:

I have a feeling I will have to wipe the laptop and reinstall everything, luckily it is only really used for Visilogic programming.

Check the top pinned post in this forum.

Share this post


Link to post
Share on other sites

I found a solution to this problem (it helped in my case, I was programming on another computer and at home project opening the same error occurred) 

The solution is as follows:
1. Open the project, do not click "OK" in the dialog box.
2. Open Task Manager, and shut down VisiLogic.
3. Restart the project, use recover, and click OK 2 times (in 2 dialog box).
4.Your project is open.
 

  • Like 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...