Jump to content
wapcs

Reboot from Ladder

Recommended Posts

Hi all, 

I realise that I can reboot from UniApps but is it possible to do a reboot from Ladder/HMI.

Reason being, my Modbus IP comms (over 3G) seems to get 'bogged down' after a few weeks/months and stops communicating. My golf course customer then angrily complains when his lake overfills because the fill pumps haven't stopped as comms is lost, I then log on and reset it manually from UniApps and away it goes again until next time. 

Id like to routinely reboot the PLC to prevent this scenario and also have a button on the HMI for the end user to press if needed rather than calling me. 

Share this post


Link to post
Share on other sites

I know what you are asking.  However, as a sort of backup.......

Doesn't your modbus connection/module/gizmo at the pump end have user settable I/O preferences that you can make them switch to if comms are lost after X minutes? 

cheers, Aus

Share this post


Link to post
Share on other sites
On 5/24/2019 at 11:36 PM, wapcs said:

is it possible to do a reboot from Ladder/HMI

This handy feature is available with Vision PLCs, but as far as I know it has not been incorporated in the UniStream line.

Share this post


Link to post
Share on other sites

I have learnt that it is possible but requires an edit to the config file. I guess if anyone else needs it contact tech support. 

It might be something they make standard in the future.

 

Thanks to Saragani for the assistance. 

Share this post


Link to post
Share on other sites

Just another question.

Is the communication problem a problem with the Modem, or with the PLC?

If you say that you have communication problems after few weeks / months and the problem is in the PLC, then maybe this issue can be sorted if we find out why it happens.

Share this post


Link to post
Share on other sites

I'm not sure why it stops communicating but rebooting the PLC fixes the issue. Any suggestions on the cause?

Share this post


Link to post
Share on other sites
On 5/29/2019 at 1:40 AM, Saragani said:

Just another question.

Is the communication problem a problem with the Modem, or with the PLC?

If you say that you have communication problems after few weeks / months and the problem is in the PLC, then maybe this issue can be sorted if we find out why it happens.

What do you suggest I do to see 'why' this happens?

Share this post


Link to post
Share on other sites

Can you contact support and explain the problem in details? (And supply a project if possible).

Maybe we can reproduce the problem, and if it's on our side then we could fix it.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...