Jump to content
spider

Touch Panel problem?

Recommended Posts

Hello,
I probably have a problem with the USP-104-B10 touch panel. I bought a new CPU and touch  panel , installed the control program and the touch panel behaves very strangely. At the touch of a button, the panel does not react to the next screen. It starts to react sometimes when I touch the screen in four corners at the same time. Sometimes it reacts only after about 1 minute. Modbus communication ceases to operate periodically. The web server works properly, without delays. Variables on the touch panel screen are also displayed without delays.
the same control program on the old panel worked properly (it was created on UNILOGIC software 1.19.83), a the same  control program converted to version 1.26.90). Now I have a big problem with it.

Share this post


Link to post
Share on other sites

Hi,

Slow PLC reaction may point to Ladder code problem/not optimal Ladder code.

If you cannot find problem - publish your project and Forum members will review project and will recommend you how to improve it.

---

When looking for solutions, please visit and search not only Forum topics, but Unitronics Help Center Articles too.
Link:
https://support.unitronics.com/
There are many available articles.
If you have solution to share, tell us know and we will add it to Articles.
B.R.
 

Share this post


Link to post
Share on other sites

From your description I am only assuming that your "new" CPU and touch are the same as the original.....it isn't exactly clear that this is definitely the case.  If they are identical, have you ensured that all firmware matches the version of the program being used?  Or go back to the original program and it's firmware?

cheers, Aus

Share this post


Link to post
Share on other sites

I checked the PLC controller carefully and noticed that the front plastic panel is peeled off the housing. Maybe this causes some reflections in the touch panel and the controller thinks that some part of the screen is still pressed. I am sending the PLC to the seller (warranty).

Share this post


Link to post
Share on other sites

 

Hi

Sometimes  a strange touch experience on the HMI can be due to how tight the  panel has been clamped in from  the back.

Loosen up the mounting screws a bit solves the issue.

 

Dant

 

 

Share this post


Link to post
Share on other sites

Hi,

I sended panel to seller. Now they are checking it.  DanT, I think you have right. When I powered-up PLC on table after I back from service, everything worked good.

 

Kris

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...