Jump to content
prietobmiguel

There are too many I\O modules without any extension cable between. ERROR

Recommended Posts

Hello,

 

Im new in Unitronics. I'm programming my first project with unitronics and came to the following issue:

I have added a digital input and output module and now i cannot compile the project, so it's a software issue , not on the PLC itself.

The error is:

IO Config 'Config 1': There are too many I\O modules without any extension cable between.

I have a 7" integrated panel with an expansion adapter : UAG-CX-XKP300

on the expanisons i have 2 modules a uis-08TC and a UIA 0402N  With this both the system has worked fine. Now i need more digital inputs and outputs, so i have  insert at the end a UID 0808R.

As I insert on the Unilogic Software the 3rd module and  intent to  Rebuild , Compile or Download, the error listed above apears and I'm not able to update the unit with this new Module.

Can somebody help me with this issue ?

Thank you 

 

Miguel

 

 

Share this post


Link to post
Share on other sites

You can define different hardware configuration options on the same project, where the configuration is decided in run time.

You have full configuration + extra 15 configurable configurations. The message suggests that Config 1 is configured without any cable (The cable is un-checked).

 

In the "Uni-I/O and COM Configuration" view, click on the PLC itself (so no I/O module will be selected)m or click the "Uni-I/O and COM Configuration" on the solution Explorer.

In the Property Window, at the bottom, you have IO Configs. Click on the 3 dots "..."

In the opened window, select Config 1 in the Combo Box, and make sure that all check boxes are checked (In your case, I think that the cable is unchecked).

 

Share this post


Link to post
Share on other sites

Thank you Saragani for the info. I did not know the possibility to do this over the Software. I have seen the configurations on the HMI panel.

I have checked the config and all items are selected.

I have also actualize to the last version of Unilogic in case this could be a problem.

The strange think is that if i eliminate the 3rd Module then i can compile. It does not allows me to insert 3 different modules.  " modules no problem… 3 modules = error.

 

 

 

Share this post


Link to post
Share on other sites

Hello Saragani,

Sorry. I have just now notice that I was looking at the wrong config.  The wire was not checked as you pointed.

What im still surprise is that the program changes the Config depending on  the modules i install. Is this normal ?

 

Thank you again for your help !!

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...