Jump to content
Sign in to follow this  
sasdiscos

Wrong 'Day Of The Week'

Recommended Posts

Dear all, 
Up until now my system has been running fine. Today the date went out. The callander shows the correct day, year time etc but in the numbers its showing incorrectly.
So today is sat and its showing 1. I thought sat was 7? Sunday should be 1, monday 2 and so on. Its been fine up until now. Ive reset, reloaded and tried every thing i can think of.
Its a UniStream7.

Screen Shot 2019-12-21 at 10.29.10.png
Screen Shot 2019-12-21 at 10.29.16.png
 

Any help appreciated.
Thanks, Steve


UPDATE
Further investigation shows that day 7 just isn't there. It goes from 6 on friday, stays with day 6 on sat now, and then goes to 1 on sunday, but then moving forward on the date to next week the same thing happens, no day 7 ????

Share this post


Link to post
Share on other sites

So, this was updated last month and worked ok for a while but today, Saturday, 18th, its back to displaying 6 as apposed to 7. This really needs to be fixed. Also, since the update I seem to be having ethernet issues dropping the modbus, don't know if this is related or a coincidence.

 

Any ideas? 

Cheers, Steve.

Share this post


Link to post
Share on other sites

Hi every one.

Just taken another look now I have a bit more time. The issue has not been resolved. I have checked and i have the latest software etc.

 

Steve

Share this post


Link to post
Share on other sites

Right, seems I haven't updated the firmware, just the software!

So updated the firmware now to 1.28.58. but was still showing as the old version. Ive done a full tear down and back up again and now all seems well.

 

Sorry for the confusion, i just hope this has fixed all my issues. (mental note, check for firmware updates as well)

 

Steve

Share this post


Link to post
Share on other sites
On 1/18/2020 at 9:20 AM, sasdiscos said:

(mental note, check for firmware updates as well)

That's an easy one to overlook.  I've gotten in the habit of assuming a new software revision includes a firmware revision, but you're not reminded by the software to check it.

Joe T.

Share this post


Link to post
Share on other sites
On 12/21/2019 at 12:26 PM, sasdiscos said:

Dear all, 
Up until now my system has been running fine. Today the date went out. The callander shows the correct day, year time etc but in the numbers its showing incorrectly.
So today is sat and its showing 1. I thought sat was 7? Sunday should be 1, monday 2 and so on. Its been fine up until now. Ive reset, reloaded and tried every thing i can think of.
Its a UniStream7.

Screen Shot 2019-12-21 at 10.29.10.png
Screen Shot 2019-12-21 at 10.29.16.png
 

Any help appreciated.
Thanks, Steve


UPDATE
Further investigation shows that day 7 just isn't there. It goes from 6 on friday, stays with day 6 on sat now, and then goes to 1 on sunday, but then moving forward on the date to next week the same thing happens, no day 7 ????

Hi,

Any solution to this?

I have the same problem, in that our week in RSA has 7 days, yet the RTC only goes to 6 days.

(Maybe other parts of the world only have 6 days?)

Bernd

Share this post


Link to post
Share on other sites

Hi Joe,

I was running an older version, and am now in the process of updating Unilogic as well as the firmaware(via Unilogic).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...