Jump to content

Recommended Posts

Hi
I need help I have a unitronics v350 and I need to control a 1500rpm motor with a 20: 1 reducer. I need to control the revolutions with respect to time and number of turns that are needed to work, the engine is controlled with an ABB drive. Example 15seconds 5 turns, I make a division 60/15 the result multiplied by the number of turns and multiply it by 20 giving 400 by the ratio of reducing motorbike. linearized with respect to the analog output according to data for 0-10v in 12 bits is 0-4095 and for the analog input 0-10v in 14 bits 0-16383.
My linearization is as follows: x1 = 0, y1 = 0, x2 = 1500, y2 = 4095, X (the result of my operation example the 400) and Y my analog output.
I activate the drive and it gives me 16 turns, it doesn't give me the 5 turns that I ask for. Help.
My analog plc output is connected to the analog input of the drive.

Share this post


Link to post
Share on other sites

Hi erebo, check the operation by going online first and manually manipulating the analog output.  If you have indeed got everything set for using 0-4095 0-10V output correctly, and also everything set ok at the drive end, manually entering a value of 1020 should have your motor's reducer output somewhere close to 18.75 rpm.  2040 should be around 75/2 = 37.5rpm. etc.

If this isn't the case then something is physically  wrong with your setup.

If it works ok, I'd be changing your maths around a bit, but that's the next explain.

cheers, Aus

Share this post


Link to post
Share on other sites
3 hours ago, Ausman said:

Hi erebo, check the operation by going online first and manually manipulating the analog output.  If you have indeed got everything set for using 0-4095 0-10V output correctly, and also everything set ok at the drive end, manually entering a value of 1020 should have your motor's reducer output somewhere close to 18.75 rpm.  2040 should be around 75/2 = 37.5rpm. etc.

If this isn't the case then something is physically  wrong with your setup.

If it works ok, I'd be changing your maths around a bit, but that's the next explain.

cheers, Aus

Hello ausman if I make changes in my linearization of more range or lower range and check with a multimeter the analog output of the plc if it reflects changes in VD voltage. I still don't verify on the drive. I will check your suggestion anyway and tell you how it went.
thanks Aus

Share this post


Link to post
Share on other sites
19 hours ago, erebo180 said:

Hello ausman if I make changes in my linearization of more range or lower range and check with a multimeter the analog output of the plc if it reflects changes in VD voltage. I still don't verify on the drive. I will check your suggestion anyway and tell you how it went.
thanks Aus

HI  aus

I'm still having problems you can check my program and I hope you can help me if I have errors

mabesapruebas.vlp

Share this post


Link to post
Share on other sites

Erebo, sorry, I can't give this time for the next few days at least.  Someone else chime in?

That said, did you actually do the online  manipulation like I suggested.  Your "still having problems" doesn't really answer the question.

cheers, Aus

Share this post


Link to post
Share on other sites

Just a quick glance and I see that you have your analog input as the output of a linearization FB in rung 10 of the linearization subroutine. That will not work. You have a lot math in rungs 8 & 9 that makes little sense to me. Until you get the motor running the way you want, simplify everything to a direct input of the RPM on the HMI screen with a readout of the RPM from the analog input visible on the screen.

Also, be sure you are using 3277-16383 for that 4-20mA analog input, not 0-16383.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...