Jump to content
Sign in to follow this  
RickM

Write .CSV delimited line to SD

Recommended Posts

I have a number of identical systems that write a .CSV delimited line to an SD card once a minute. Occasionally one of them will hang, with SB 344 (SD: Write .CSV delimited line to SD in Progress) on and cannot be reset. I have re-initialized the PLC to get SB 344 to reset. What is the best way to reset this bit and what is causing SB 344 to remain on?

Rick M.

Share this post


Link to post
Share on other sites

Hi Rick,

Which VisiLogic version are you using?

Please make sure you are using VisiLogic 8.6.1

Which OS version are you using?

Please make sure you are using the latest OS 3.1(19).

Does this bit stucks always on specific system or randomly?

What is the status messages value of the function "Write Delimited Line"?

Please sure also that the max vector you configured in the function "Create Delimeted line" is big enough to hold the vector. (Try to increase the vector lenght)

If you still face the same issue please attach also the applicaiton and steps how to simulate the problem.

Share this post


Link to post
Share on other sites

Hi Ofir

Using V570, O/S 3.1(05) and VisiLogic 8.6.0 Build 0

I currently have 10 systems running and have seen it happen a month ago on one of the units and two days ago on two other units, unfortunately I did not record which unit it was a month ago. The two units were reset by the customer so I don’t have the status message value of the function. The units are due for a program update so I will increase the vector length at that time.

I can update to VisiLogic 8.6.1, I see in the version change document that the email function GUI has been improved so I will review prior to my program updates as the units are emailing with attachments.

The units are mobile and I connect with a ethernet VPN connection through a cell modem and have not tried an O/S upgrade over the modem, so will test when I have someone at a unit.

We are in the process of commissioning three units and building an additional 45 units so I will make sure they are up to date.

Rick M

Share this post


Link to post
Share on other sites

Hi Rick,

Next time it happens, please make sure to get the status messages of this function so we will be able investigate this issue.

Also please note that ejecting the SD and inserting it back also should release this system bit.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...