Jump to content

Search the Community

Showing results for tags 'Modbus'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Our Community
    • Come on in!
  • News and Announcements
    • UniLogic 2021-- UniCloud IIoT Cloud Platform, EtherCAT & more!
    • VisiLogic:9.8.64 - Link to mobile app, Ladder: 2x the Space!
    • New!!! ***** U90 Ladder*****
  • UniStream HMI + PLC Programmable Controllers & UniLogic Software
    • UniStream: Hardware
    • UniLogic Software
    • UniLogic UDFBs
    • Industry 4.0, IioT, MQTT, OPC UA
  • Vision, Samba, Jazz and M90 PLC + HMIs & Software
    • Vision & Samba PLC + HMI Controllers & VisiLogic Software
    • Jazz, M91 PLCs and U90Ladder
  • Motion! Servo Drives, Motors, Actuators, & VFDs by Unitronics
    • Motion: Unitronics Servo Drives, Motors, Actuators, VFDs--by Unitronics
  • Software Utilities
    • SD Card Suite
    • Remote Operator
    • Remote Access
    • DataXport and DataXls
    • UniDownloader
    • UniOPC
    • UniDDE
  • Utilities for .net and Visual Studio
    • Unitronics PCOM Protocol
    • COM Object ActiveX .dll
    • .NET driver
  • Project Design
    • ...I have a project...what hardware do I need?
  • User Application Stories
    • Just finished a great project?
  • Tips and Tricks
    • Best Programming Practices
    • Tips and Tricks
  • Job Board
    • Projects seeking Programmers
    • Programmers seeking Projects
  • General Discussion
    • We're Listening...
    • The Lounge
  • News and Announcements Copy

Blogs

  • Unitronics' Blog: PLCs, HMIs and more
  • Saragani's Blog
  • Simon's Blog
  • Ash Neilson's Blog
  • Joe Tauser's Blog
  • Unitronics en Español
  • Powered by AMPS
  • Alldrives UK's Blog
  • Unitronics, Howman Style
  • PLCNewbie's Blog
  • Telestar Automation Blog
  • Webinars Collection
  • Tim's Corner
  • Blog
  • TELESTAR (Italian)
  • i4 Automation
  • i4 Automation (UK)
  • Unistream UDFB's

Categories

  • From Headquarters: Sample Applications
    • From Headquarters: VisiLogic
    • From Unitronics: U90 Ladder applications
  • User-submitted Applications
    • From Users: VisiLogic applications
    • From Users: U90 Applications

Categories

  • Articles
    • Forum Integration
    • Frontpage
  • Pages
  • Miscellaneous
    • Databases
    • Templates
    • Media

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


AIM


MSN


Website URL


ICQ


Yahoo


Jabber


Skype


Location


Interests

  1. I would like to communicate with an instrument that is using Profibus port to read analog and digital values. Is it possible to use an an external protocol converter with the Unistream (RS485 or CAN) port to connect to Profibus Slave device ?
  2. We have an issue regarding the Modbus TCP/IP communication with a third party HMI(Weintek), the read only bits can be read but I can't seem to write data on the PLC, how can I match the address that unilogic uses to the Modbus Standard( 0x 1, 0x 2, 1X 1 and so on) does this address matches exactly to that standard, say, If we configure a Coil to address 1 read only does this translate to 0X 1?, and if a second coil is configured as address 2 read/write does this means 1X 1? or 1x 2?. As I stated before, Our master HMI can read the coils configured as read only, we can even read and write regis
  3. Hello, These days I'm having a problem using modbus to reading pressure data from TROX terminal unit. It is kinda simple idea - 7 slaves (TROX units) and V700 is master and gets all the data. But as I'm conneting modbus though all of them I get error that there is no connection between TROX units. Slaves ID are set properly, cable polarity have been checked too. Maybe there are some other problems that I don't know? Thank you kindly for answers.
  4. Hi, I'm having hard time displaying data on V700 PLC. After MODBUS config and reading holding registers HMI still shows 0. Do I need to write data to data table and only then display on HMI? Data has to be read from MIO 12-V I/O module. Network ID matches, start of vector links to hmi variable. What could be done or I did wrong? Thanks. I'm attaching vlp file here
  5. Hi, I'm having hard time displaying data that I get through MODBUS. Need to read from multiple slaves, but after download display still shows 0. Maybe do I need to write data to data table and then display on HMI? Or I can just display data vector? I'm really confused, thanks in advance for your help. P.S. Program attached below. Thermofisher.vlp
  6. Hey guys, I'm often needing to use advanced modbus features because ill need to have dynamically adddressed slave ID's, or changing registers etc, etc and i cant use the built in configuration to do so. Also - the Advanced modbus still require a good bit of logic to be built in order to achieve a good Tx and Rx. I built this UDFB to be used as a single operation which accepts 4 Function In parameters, and one Function out. Example Ladder Note how the function is called, Param 'D' must be reset immediately after the function call: Ladder Image Input A is a struct with
  7. Hi; Trying to connect to a Gardner Denver Airsmart Controller Comm Module. Serial Interface - RS232 works. Trying the MODBUS TCP UDP protocol on their ports 2000 and 2001 - no luck yet, we can ping the IP OK, just no connection for MODBUS Read Registers(3) Any one had experience with this unit? Dan
  8. Hi Guys, Just doing a addition on a project I have 12 x VSD danfoss drives working great over the last 12 months on Modbus TCP,/IP. Using control word and speed reference for control, the client has just installed a ABB drive a ACS550, taking the modbus drive count to 13, I can easily poll the drive and read the drive feed back like 102 (40102) etc, However I am having difficulty writing the control word as a Hex code of 04FF to (1) or 40001 to start the drive or the speed reference between 0-20,000 to (2) 40002 Does anyone have any ideas I have tried both 0 &1 as zero o
  9. Can someone explain the format that the IP address is displayed in the Modbus IP communications status bit and how I can display it as a usual IP address like: 192.168.1.201 Cheers
  10. Hello, I just got informed about an issue with the program I have made for a Samba SM35 regarding Modbus settings. I use a Com Init block directly after a power-up bit that initializes factory com settings. If I enter Information Mode and change the serial settings for RS485 there, everything is fine until a power loss. The settings are overwritten at power-up. Is there a way to prevent the settings from getting restored to Com init settings after a power-loss or unit shut down?
  11. Hello, I'm using JAZZ JZ20-R31 as a master to comunicate via modbus. Is there possibility to use another master device on the same line which would read data from JAZZ? Requests from one master would be about a minute interval and around 15minutes from the other, so there would be little chance for interference. I know this isn't the right way to do this, but just curious... Is it possible to do this or is JAZZ somehow "locked" and unable to be read by someone while JAZZ itself is operating as a master? Thank you, Regards, Pawks
  12. Good evening ladies and gentlemen, I have 4- V430-J-TA24's, serial (RS232, 9600, 1, none) MODBUS, one as a master (MTU), and the other 3 as slaves (RTU). port 1 on each unit connects to it's respective radio modem. The MTU polls the 3 RTU's successfully and the cycle repeats. Here is my problem: how do I detect a comm failure on the slaves that will set a MB to clear my outputs and registers? The master reads a register from RTU1, here it can use the status message from the RHR #3 and use a compare if MI96 (rhr#3 status) = D#5 then ----[R] (MI100, the value displayed on MTU, fetched from
  13. Hi everyone. I tried to use a MODBUS configuration using an indirect declaration of SLAVE ID, but didn't work. (see example in index 2 and 3 below) If I declare the SLAVE ID in a direct way, all OK. My problem is that I have to read several slaves from the PLC, and is realy hard to do with a fixed Modbus configuration. I am using a V130 in revision 9.6.0. Thanks in advance. Regards, Javier. P.D.: Sorry if I posted this twice. I couldn't find the first post.
  14. update: 12-10-16 I take that back, I failed after two weeks of trying every conceivable configuration to implement a complete working model of serial MODBUS with read holding register and write coils exchanges to four vision slaves over RS232 radio modems. Has anyone out here successfully setup a Unistream master to a Vision slave, serial, 232 over modems (RF), read registers (more than one) and write coils; without errors? For example sequentially reading five 16 bit integers and in next line of periodic slave table writing a 10 bit array of coils (or a single 16 bit write regist
  15. I notice that the Unitronics MODBUS communications function, "Read/Write Mixed Data", crashes the communications if I try to use it between a Vision controller and a UniStream controller. This is a VERY handy function and I'm wondering if there are any plans to make the UniStream compatible with this function.
  16. Hi everyone. I tried to use a MODBUS configuration using an indirect declaration of SLAVE ID, but didn't work. (You can see an example in index 2 and 3 of the attached image) If I declare the SLAVE ID in a direct way, all OK. My problem is that I have to read several slaves from the PLC, and is realy hard to do with a fixed Modbus confifuration. I'm using a V130 in version 9.6.0. Thanks in advance. Regards, Javier.
  17. Hello! I have a next project where I have to use module EX9024D. For this project I use Unitronics Samba (SM43-J-T20) with v100-17-rs4 module (because this combo is what I have right now). Operation manual for EX9024D: https://www.expertdaq.com/media/downloads/ex-9021_ex-9022_ex-9024.pdf Basically I have to send #023-02.500 command to module (page 20). This command will generate -2.5V to output 3 (total 4 outputs, 0-3). This task is little over my head, especially when it comes to using ModBUS, so I will need help. How do I transmit this kind of command over ModBUS (I b
  18. Hi there, i'm not able to read 32bit float big-endian from Janitza UMG104. Connection is over COM1 in Modbus mode, periodic trigger activated by pushbutton and set slave-name (bit) to 1. This works fine for the Modbus TCP slave, which provide me system information. The powermeter i try to read, deliver me important informations which i later need to add together with sensor values to a data table. Reading fails at the point, the 32bit float comes in. I tried: Register addresses 19018 (current, A), 19026 (power, W) and 19034 (power, VA) with own Tags as REAL, with memory
  19. Hi, I need to connect a USP-070-B10 Master(client) to 6 remote Modbus TCP I/O Slave (server) (http://www.moxa.com/doc/man/ioLogik_E1200_Series_QIG_v4.pdf). Do I need 6 different socket? May be socket in Unistream are unlimited!!!
  20. Hi, Would someone explain me how can I send correctly variables type REAL (MF`s) over Modbus-TCP? I am working with a PLC V1210 with Internet card V200-19-ET2, it talks to an Anybus X-gateway ( AB7629-F) which is Profibus-Master and Modbus Slave then the Anybus will send the data to a Nachi Robot CFD controller. I already set the comms between all devices and I can send/receive data to each other. My problem starts when I try to send the variable with decimal point (i.e 1.5) to the robot. But let me explain where I have got so far. Before send it to the robot I get the MF0 and
  21. Hi, I have a Vision V1210 Controller that is supposed to read float values from pH meter over RS485 MODBUS RTU. All the communication is fine, using "Read Float Registers" FB the float value is stored in two consecutive MI registers (MI0 and MI1). I can see that retrieved value is 32bit float ordered big-endian (I believe that's IEEE 754) and I was wondering if there is some way to display it on screen? One way would be converting it to some integer representation so I can easily put it in a numeric box and use 1.2 decimal format (pH values should be in range 5.00-9.00), but I haven't
  22. Hello again, since your answers are very helpful and I could not find information I need on this forum, I`m starting new topic. I need to set up communication between V280 and multimeter DMK 22 by Lovato. Here is the tutorial they sent me: https://www.sendspace.com/file/trigbh(file is too big to be attached here on forum) I have several problems with understanding the whole communication. I have working MODBUS IP communication between PLC-to-PLC, where the communication is done through MODBUS R/W Mix, which I understand how it`s done. Here I need to get from the slave multimeter
  23. I'm developing SCADA graphics, and was just supplied with an address list from the PLC programmer. After looking over manuals/webinars/forum posts I'm looking to get some verification on whether I got the Modbus addressing correct or not. This is my first experience having to interface with an Unitronics PLC... I'm used to AB or SCADAPacks mostly...
  24. Hello, I have a problem using MODBUS communication with JAZZ JZ20-R31. I have two slave devices connected. I just read from the first one, and i just write to the second one. I had the first one alone before i added the second one and communication worked just fine. Problems came when i added the second device (the second one is a PLC from another company and it's used to send written data to the web). Yesterday communication worked for a few cycles, but after that it completely stopped, even with first device - there were no LED lights blinking like it should. Toda
  25. Hi all I am using a V430-j-t38 with add on Ethernet card. The problem I am experiencing is with the built in Com port, I have set the dip switches to rs485 and we use this port as a Modbus slave from a Motorola Ace3600, I am being sent a Vector of values in MI 141,142,143 The problem is my plc interprets the information wrong and loads all the data into MI 141 as 19456 when at the moment it should be 36, 1796 & 666 but the current values it should send don't really matter I seem to just get 19456 The data being sent doesn't seem to be a problem nor does the PLC rea
×
×
  • Create New...