Jump to content

Communications stop when a variable frequency drive in use


Recommended Posts

This is not a question, but a issue that has been soved that might be usefull to someone else to avoid pain.

V1210

V9.4 Visilogic

Windows Vista 32 bit

The initial problem was that my communications on com port 2 (my VFD connection) is always perfect with no issues, but as soon as I turn on a VFD (variable Frequency Drive) the communication between the PLC and a computer instantaneously and permanently stops until such time the VFD is stopped (not powered down) and then the communications can be re-established to the PC.

I have tested out just about everything I can to make sure that the answer is correct and not accidental.

1) I have an RS485 with termination using Modbus RTU protocol on com port 2, 19200 com speed 8,2,none connected to a FUJI brand VFD

2) I have com 1 at the default 232 connection to go to the computer using a USB to serial adaptor the has been in constant use for 2 years and never had any trouble (cable from “cables to go” the model is 26886)

3) I have tried shielded com wire both grounded and ungrounded. (no help)

4) I have altered the output carrier frequency of the VFD (Higher the carrier frequency on a VFD the more electrical noise is generated) (no help)

5) I have tried with a motor connected and not connected both with and without grounding. (VFD wiring to a motor can act as an brodcast antenna) (no help)

The answer is the USB to serial cable that has and does work when no VFD is running is the root cause of the condition.

I have other USB to serial converters and have replaced the original with a metal cased USB-COMi-M that was purchased from www.byterunner.com for $59 and when using the different USB to serial adapter everything works smoothly with no issues under all conditions. I have also run direct to a 9 pin serial port with the standard programming cable and all communications are perfect with or without the VFD running. I think I can correctly and safely say that nothing in either the Unitronics hardware or software is to blame for the troubles I have had.

It has taken me most of a day to figure this out so I figured I would pass the information on since it might be useful at some point in the future when someone else has a similar problem.

Keith

  • Like 1
Link to post
Share on other sites

The "plugged-in" aspect of the laptop is VERY important. When you're on battery, everything is isolated. When you're plugged in, the negative of the power supply and everything else (including the USB port) is grounded through the neutral and that will often kill communications.

Joe T.

  • Like 2
Link to post
Share on other sites

Well I have finally had a chance to test the same USB to serial converter on my new laptop.

Lenovo Thinkpad T420

Windows 7 professional

The resultsa re the same except that the Windows 7 OS gives an actual arror message that says "Internal error - retrieving device control bloabk for the port". This causes a hard crash of visilogic also in Windows 7 (both computer are running V9.4 Visilogic).

With the power supply plugged unplugged I actually got a blue screen of death when I started the VFD. So I'm not going to retry that again, but I ran the scenario with the power cord plugged in 3 times just to see if it was repeatable.

Everything works fine with no issues when using the USB-COMI-M.

Well now we know :)

Link to post
Share on other sites

I checked out the byterunner site and followed the links on the driver. This device is using the FTDI chip, as opposed to the Prolific chip we've been selling for years. I also noticed that the Unitronics-supplied USB->Serial converters (MJ10-22-CS35) have just recently changed but I haven't played with one yet. Question for the Creators - are we still promoting the Prolific chip or have we moved to something else?

Joe T.

Link to post
Share on other sites

It sounds as though there are some severe isolation issues with with the hardware. It does not sound like ports1 and ports 2 of the v1210 are isolated.

I am curious if you just have a defective piece of hardware, or if this is a problem (like Joe suspects) with that entire line of cables.

Link to post
Share on other sites

I have always had periodic disconnects with my older USB converter, but this was always when I was in a field condition on an old laptop. The USB ports were "loose" to say the least (they would wiggle up and down with my fingernail if I pushed on them. So I always figured that that the bad USB ports on the old laptop were the culprit. I got a new laptop a few months ago and the ports are tight and no issues so when I got the disconnect in the field when I was near a VFD I knew something was up, but was unsure as to what.

I had to map some information to a VFD so I set up in my office and got all of the issues that this chain has talked about whenever I would ask the VFD to fire the IGBTs and make a motor turn (even if the VFD output was 0.00 Hz). We also program some Rabbit controls here and so we had the two of the Bytrunner products (it is a 232 and 485 to USB converter) and the issues went completely away.

I suspect that there may be something physically wrong with my old converter, but if I look back at field history where I have had a heck of a time staying connected I'm actually leaning Joe's way and agree that the different hardware in the Byterunner product is more the answer to the improved results that anything else.

Keith

Link to post
Share on other sites
  • 7 years later...
On 7/10/2012 at 11:30 PM, Walkerok said:

USB-COMi-M

Dear sir,

 

May i get the specification for that metal case converter.

Because am getting the same issue what you faced, in MODSCAN32 am getting "invalid response" and "MODBUS message timeout" once after the VFD starts with 0Hz.

 

Thanks,

Trinitton

Link to post
Share on other sites
On 12/31/2019 at 8:35 AM, Joe Tauser said:

That converter is isolated.  You'll need something like it.

Go to byterunner.com and search for that part number.  All the specs are there.

Joe T.

 

am having the converter HEXIN 2108B and will this do the same as USB-COMi-M

because nearby shop i can able to find HEXIN 2108B and not USB-COMi-M..

 

please suggest

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...