Jump to content

Very slow HMI editing in Visilogic


Recommended Posts

Unfortunately I've made two changes simultaneously and I don't know what is the culprit. I had to replace my laptop - the old one was a Win XP, 32-bit, that was several years old, running Visilogic 8.6.3. My new one is Win7, 64-bit. I'm now running 9.4.0 and editing HMI screens in Visilogic is excruciating. Granted, it certainly wasn't a speed demon before, but every time I click to select or deselect an object on an HMI screen can take several long seconds before I get the cursor back. If I have several objects selected at once it can take 10 or 20 seconds or more just move them one pixel, depending on the complexity of the objects. This new laptop is fully decked out with the second gen Intel Core i5, 8GB Ram, etc. It is FAST with every other piece of software I own. Noticeably faster than the previous laptop, but not with Visilogic. Any suggestions on what is slowing things down? I've got to get this fixed to get my productivity back to where it needs to be. Yes, I have disabled UAC.

Another problem is that the operand descriptions in the box in the ladder section are only two lines (the address, e.g. MB50, plus one line of the description). Before, I had three lines total - the address plus two lines of description. Is there a way to control this? It's extremely frustrating to have to hover over every operand to figure out what it is.

Link to comment
Share on other sites

Thanks, Damian. I thought I had seen at least one previous post on this, but was unsuccessful in searching for it.

Unitronics Technical Support: Is this a known problem? Do you have any suggested solutions, or is this just a conflict with certain computers that is too rare to spend any time on to correct? How about the issue of only 2 lines displayed in the operand description box? Anything I can do about that? Thanks.

Link to comment
Share on other sites

Thanks, I'll do that. But how about the simple question about how many lines of text are displayed in the operand description box? My desktop computer runs WinXP and Visilogic 8.6.3 with a screen resolution of 1280x1024 and I get 3 lines in the operand description box. My laptop runs Win7 and Visilogic 9.4.0 with a screen resolution of 1920x1080 and I only get 2 lines. What determines this? This is a very simple basic question that someone at Unitronics should have an instant answer for, at least it would seem to me.

Link to comment
Share on other sites

As I said, I'll send an email to support, but here is the screenshot for those interested. The left side was taken from my WinXP desktop PC running Visilogic 8.6.3 with a screen resolution of 1280x1024, the right side is from my laptop running Win7, Visilogic 9.4.0 and a screen resolution of 1920x1080. I think it's clear why this is a problem.

Link to comment
Share on other sites

I've been poking around in Windows 7 and found the problem. In the Display settings there is a setting for text size. This, of course, is not new to Win7, but at least on my computer, it defaults to "Medium - 125%" instead of 100%. this had the effect of increasing the font size in Visilogic. I hadn't checked this because I had never changed it and assumed the default would be normal size rather than larger - stupid me. This may also have an impact on the delay times when moving or deselecting HMI elements - I'll check and report back.

Link to comment
Share on other sites

I've been poking around in Windows 7 and found the problem. In the Display settings there is a setting for text size. This, of course, is not new to Win7, but at least on my computer, it defaults to "Medium - 125%" instead of 100%. this had the effect of increasing the font size in Visilogic. I hadn't checked this because I had never changed it and assumed the default would be normal size rather than larger - stupid me. This may also have an impact on the delay times when moving or deselecting HMI elements - I'll check and report back.

It does seem odd that the default on a laptop would be 125%.

I would be very interested to know if this affects the delay time.

Link to comment
Share on other sites

I learned my lesson a long time ago with Visilogic and windows settings. The entire first year I used it (under XP), there were many things on the screen that I wasn't seeing that I wasn't even aware that I wasn't seeing. I remember one day I was frustrated because I wanted to know where my pixel location was on the HMI screen and I complained that they needed to add this feature. I was then informed that in fact that feature was already there. Where?!? Well after some investigation and monkeying around it was found that the "Silver" theme I had chosen didn't jive well with Visilogic and literally caused many things not to display (including the little pixel location box). ARGHHHHHHHHHHHHHHHHHH!!

That is another thing they need to be wary of on NG is try to make sure they program things in such a fashion that the windows setting and themes don't interfere with the experience.

Link to comment
Share on other sites

>Well after some investigation and monkeying around it was found that the "Silver" theme I had chosen didn't jive well with Visilogic and literally caused many things not to display (including the little pixel location box). ARGHHHHHHHHHHHHHHHHHH!!<

Really? wow--I had never heard that. We have a couple of R&D people who are colorblind and don't use the standard themes, and I don't recall anything like that.

I'll pass this one to the appropropriate peoplle.

Link to comment
Share on other sites

I have a fresh install of Win 7 and mine defaulted to 100%

Damian, what is your screen resolution? I wonder if, similar to what Cara was mentioning, Win7 decides to default to 125% on computers with higher resolution. I specifically ordered my 15" laptop with 1920x1080 because I wanted more pixels available for Visilogic. I wish I could find one even higher (without going up to 17").

Link to comment
Share on other sites

It does seem odd that the default on a laptop would be 125%.

I would be very interested to know if this affects the delay time.

My laptop is an HP - maybe it's an HP thang. :)

By the way, Cara, I think changing the Windows font setting to 100% from the default 125% seems to have also solved the problem I was seeing with delays during HMI editing.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...