Jump to content

Recommended Posts


I need to update an old project that was created in VL v8.0.1. I used the swapper, downloaded the files, and registered the version. When I try to open the v8.0.1 software I get  "run-time error '13': Type mismatch". I tried it on few computers, swapper v9.02 and swapper v9.04, from VL 9.5.0, 9.4.0 and 9.3.1 and they all gave the same error. However, when I completely uninstall the software and reinstall VL v8.0.1 it's ok. How can I fix it so I can use few version without uninstalling/reinstalling them?

Link to comment
Share on other sites

Hi Omer, 

It is most likely a setting wihtin the PC, have you checked the UAC. It can be the UAC setting, you should also ensure your windows updates are current and you have administrative permissions on the PC. Please try to run as admistrator,(right click>Properties> run as administrator)


Link to comment
Share on other sites

  • MVP 2014

Make sure you use the right shortcut when starting a swapper version.  If you install, let's say, Visilogic 9.5.0 from the web it will create a start menu shortcut.  If you then swap to 8.0.1 the original start menu shortcut won't work as it still points to 9.5.0.  The way around this is to click "yes" on the option at the end of the swapper process to "Create shortcut to registered verison on Desktop".  However make sure you keep deleting the old shortcuts to help you keep track of which one is active.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...